Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

Kernel Module Update was required when opening VMWare client (vmplayer) then following error occurs. Any idea would be appreciated.

Unable to start services.
See log file /tmp/vmware-root/setup-NNN.log for details    (Note: NNN looks like random numbers)

On GUI that show progress of updating, "Virtual Netowork Device" show red flag appears. Content of .log file is here:

This page suggests installing linux-headers-generic and build-essential, which are already installed on mine (thus no good).

This could be 1st execution of vmplayer on my machine since I upgraded to Ubuntu 12.04 from 11.10.

Environment: VMware Player 4.0.3 build-703057

share|improve this question
up vote 2 down vote accepted

I had the same problem, that VMWare didn't work any after updating to Ubuntu 12.04. Instead of installing a patch from an untrusted page, I just downloaded and installed the latest version VMware-Player-5.0.0 from the VMWare-Page:

So far, it seems to work properly. I hope it's OK for you too.

share|improve this answer
While @izx' solution worked perfectly (esp. at that moment when I asked this question), I feel this is more ideal and worked just fine on my machine. So I re-chose this as an answer. – IsaacS Sep 2 '12 at 6:13

VMWare is behind the times and the VMWare modules will not compile by default on kernel 3.2, which Ubuntu 12.04 uses.

Please use the patch available in this blog post, and then try to compile again.

I can confirm that the patch worked for me on both VMWare Player 4.x and Workstation 8.x on Ubuntu 12.04.

share|improve this answer
It works perfect. As I commented in the same blog, only tweak I needed was to modify plreqver with correct vmplayer version, in the given .sh file in the patch ( Thanks! – IsaacS Jun 3 '12 at 14:59
On a follow-up note, It happens with 4.0.4 but same patch was effective. – IsaacS Jul 21 '12 at 14:29

It worked for me also, only changing the plreqver variable to correct version (in my case 4.0.3) as mentioned above.

These are my system versions:

  • vmware-player

  • Release 12.04 (precise) 32-bit

  • Linux 3.2.0-24-generic-pae

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.