Sign up ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed ubuntu server 12.04. The server detects the modem, but I can't edit mobile broadband settings (to input username and password) in network connections

share|improve this question
How are you trying to edit this, and what happens when you try? Or are you asking how to edit it, in the first place? – Eliah Kagan Jun 1 '12 at 21:54

2 Answers 2

If you are asking how to do it-

As pointed out by @Eliah kagan,my answer points to a graphical way that may not be available in Server edition.And as suggested by him,I keep the answer intact with an addition of a possible useful link.

This link may help for the server edition-

While for a graphical way-

  • Click on the Network Connections indicator on the pannel and select Edit Connections-

enter image description here

  • Then select the Mobile Broadband tab and select the connection and then click on Edit.

enter image description here

  • Then again in the connection,Under the Mobile Broadband tab,enter the details-

enter image description here

  • After that,Save and exit.
share|improve this answer
I downloaded d ubuntu-desktop, so there's a gui – Imman Jun 1 '12 at 22:34
Just to clarify things, I clicked add on the mobile broadband tab, everything works fine until when I had to input number, username, & password; the fields are inactive, and the save button is also inactive. How do I make these fields editable? Thanks – Imman Jun 1 '12 at 22:51
Are you the administrative user?? To check,go in user accounts in the accounts menu in the pannel and check if your user type is administrator or standard – Nirmik Jun 2 '12 at 9:11

Under Ubuntu 14.04 it's all much easier, but there are still a couple of issues.

I'm in the UK. My mobile modem is a ZTE MF730M connected to the Three mobile network. I had to connect the device to a Windows machine and register it with Three before it would work. The first time you plug the modem in, it connects you to the Three website to allow you to register. Once you have done that, you can access other websites.

Next issue: the device includes a bit of data, which holds Windows drivers and windows config stuff. It looks to the host computer like a USB CD-ROM. When you connect it to your Ubuntu machine, it automounts the "CD", which disables the modem. To fix this:

df -k

to find out the mount point:

/dev/sr1      4354      4354      0 100% /media/simon/ZTEMODEM

So in my case that's /dev/sr1. Unmount it with umount:

umount /dev/sr1

and the connection starts to work.

If I open the system settings tool and look at the network settings, there are now two "Wired" entries. One has two arrows next to it, one up, one down, and represents the connection through my mobile modem that has just been set up. The other has a picture next to it showing an RJ45 socket with the plug pulled out. That represents my real wired connection.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.