Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have set Firefox as default web application in Ubuntu, but external links (like clicking a link in Pidgin) still get opened with Opera. Does anyone have a clue on how to fix this? Thanks.

share|improve this question
    
I would leave this as a comment but I don't have the permissions yet. Could you tell us: how you set FireFox as the default (i.e. through system settings or in a prompt); and is simply removing Opera from your system and option. Thanks –  Garry Cairns Jun 1 '12 at 21:37
    
What is the default browser in Pidgin --> Preferences --> Browser –  pl1nk Jun 2 '12 at 0:39
    
how you set FireFox as the default (i.e. through system settings or in a prompt); and is simply removing Opera from your system an option? (comment by Garry Cairns in answer) –  Mahesh Jun 2 '12 at 1:03

2 Answers 2

Default applications are specified in All Settings -> Details -> Default Applications.

If default Web browser is set there to Chrome, but links from other programs are still being opened with previously set default browser, this might be either some sort of a caching issue of Gnome, or 3rd party application - in your case Pidgin.

This is a blind guess, but I think I would try to reboot, and if still no result, would purge Pidgin and then reinstall.

Another option would be to remove Opera. Since you already have your favorite browser, most likely you don't need the other one, unless you have a special reasons for that.

share|improve this answer
    
Please elaborate your vote-down. –  Andrejs Cainikovs Jun 2 '12 at 2:11
1  
Quite a few down votes without reasons. Come on, that isn't fair or helpful. –  user25656 Jun 2 '12 at 10:14

I had similar case - chromium wanted as default browser, but want also keep opera installed. Evince kept opening links in Opera, even I set chromium as default browser with update-alternatives. In my case helped setting x-scheme-handler/http=chromium.desktop to $HOME/.local/share/applications/mimeapps.list as shown in superuser.com.

Also the advice to run strace to see what is happening was useful.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.