Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I stupidly downloaded the 64-bit amd version and installed it on my system.

Everything worked flawlessly. But my friend suggested it wasn't the supported version for my system since I'm running a dell xps 17 with i5.

So I installed the 32-bit version and, initially, all went smoother and faster than with the 64-bit version. But once I installed gnome 3.4 my life got a bit harder.

I got system errors, my drivers from nvidia weren't supported, etc. I followed online advice, but it didn't help.

My question is if it is possible that the 64-bit amd version is better for my system?

share|improve this question

3 Answers 3

If you are having problems with video drivers on an XPS17, your main problem is that you have an optirun video card setup, as do I, where you have an onboard intel video card that sucks, and the optirun nvidia card, that you cannot enable without a plugin called bumblebee. Your problem isn't gnome, your problem is that you cannot simply disable the intel card and use an nvidia driver; X doesn't like using two different drivers in one session, and you can't simply disable the intel one or you won't be able to boot. Unless you can rig up two different X sessions, one with shitty intel card to boot up, and the second with nvidia drivers setup, the only way to run 3D is sudo apt-get install bumblebee, then call optirun app-to-run-with-3d.

I would recommend setting up one user account to boot into the computer with, and a second account you can load to a different session. So, you boot into Alt+Ctrl+F7 using intel+unity/whatever, and load up a new X session for a different user on Alt+Ctrl+F8 with nvidia+gnome 3.4.

If you choose the route of running multiple xservers, make sure to read up on xinit: http://manpages.ubuntu.com/manpages/lucid/man1/xinit.1.html

share|improve this answer
    
An update for you, I currently have my nvidia card setup with bumblebee + optirun, and my intel card running at full power. My path to success was: Install absolute newest nvidia drivers I could find. Install bumblebee, make glxgears work. Now intel is broken because nvidia drivers are getting loaded. Move nvidia drivers to a non-system folder, in /etc is fine. Point bumblebee to the libs it needs, but make sure intel sees none of it win. It can be a long and brutal process, but it does work. If you follow the advice on bumblebee site, you will get there quickest. –  Ajax Jun 14 '12 at 8:37

If your system is 64-bit (which it is), you were right to have tried that first. On the other hand, 32-bit will work on any machine.

share|improve this answer

Your friend is an ... uh, uninformed and mistaken person. As already stated, the instruction set of an Intel Core i5 completely supports the 64-bit version of Ubuntu. In addition, it looks as though your Dell XPS 17 has 6 GB or more of memory so there is no real advantage to using the 32-bit version. The 64-bit would make better use of your computer's CPU.

However, it is also true that the 32-bit version should also work on your system. So there is a question as to why you started seeing errors.

Could you please provide more details about how your installed the different versions of Ubuntu. The safest way to do it would be to erase the 64-bit version and do a 'clean' install of the 32-bit version. Did you do this?

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.