Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm now using Ubuntu 12.04.

In earlier versions you could associate a filetype with a specific command (e.g. self-compiled binary) by selecting "Open with" in the file's properties and select the command by providing the file path manually if it wasn't already in the list of applications.

Is this possibility gone?

The only way I found now is to create .desktop files and edit the mimetypes via an text editor.

share|improve this question
add comment

2 Answers

I think you are looking for an answer like this. A user has asked for help on how to open fits file type that is not supported by default ubuntu programs.

IraGainesUK has posted the answer at http://ubuntuforums.org/showpost.php?p=12242314&postcount=5

I also can't believe it me took this long to figure out how to do such a simple thing in 12.04(!!), but the simple way is this:

1) Install Ubuntu Tweak:

sudo add-apt-repository ppa:tualatrix/ppa
sudo apt-get update
sudo apt-get install ubuntu-tweak

2) Open it up on the command line:

$ ubuntu-tweak

3) Navigate to Admins > File Type Manager and click All. This may take a moment whilst it scans all your mimetypes.

4) Uncheck Only show filetypes with associated applications at the bottom (again, may take some time).

5) Click anywhere in the right-hand panel and start typing fits to begin searching for the FITS document mimetype. Hopefully you should find it.

6) Double click it, and click Add and then your custom command (for me, topcat, for you, ds9).

I should note that I have tested the solution and it worked well for me.

share|improve this answer
add comment

If you right-click on any file and go to properties you'll find a dialog option to set the default application for opening such files.

share|improve this answer
2  
But "Add" is greyed out... –  Izkata Jul 1 '12 at 4:39
4  
Actually, "Add" just moves where in the list the already-known programs are, so this answer doesn't answer the question. We want to know what happened to custom-defined commands. –  Izkata Jul 1 '12 at 4:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.