Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

As the title says I have problems with the driver after updating to 12.04. The GUI doesnt start anymore, I only see the terminal. I have googled this for a couple of days now and have tried different things like running commands for update, upgrade and tried to uninstall and re-install the NVIDIA-drivers but with no success.

No matter what I do I get this message: "Error: API mismatch: the NVIDIA kernel module has version 295.40, but this NVIDIA driver component has version 295.49. Please make sure that the kernel and all NVIDIA driver components has the same version."

Is there anyway I can fix this from the terminal?

share|improve this question

closed as too localized by Jorge Castro, Mitch, Thomas W., Jjed, Stephen Myall Sep 13 '12 at 14:18

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Please see this, if you're still around. –  Jjed Sep 13 '12 at 14:06
    
Could this be re-opened? It has just solved my problem, so clearly wasn't entirely localized... –  DNA Jan 31 at 22:56

3 Answers 3

Looks like you didn't uninstall your previous driver version. This can happen because nvidia-current-dev is of version 295.40 and nvidia-current-updates-dev is of version 295.49 as reported.

If you've installed the nVidia driver from Ubuntu's Additional Drivers dialogue

, try sudo apt-get purge nvidia* then try reinstalling by sudo apt-get install nvidia-current-updates-dev then reboot.

If you have used the .run file from nVidia's website

then go to a console by pressing Alt+Ctrl+F1 and then run nvidia-xxx-pkg1.run --uninstall to remove the previous driver components. Now give a reboot and see if that works. If not, then execute sudo echo "blacklist nouveau" >> /etc/modprobe.d/blacklist.conf so that the default nouveau driver for nVidia chipsets are not loaded instead of proprietary one. Finally install packaged binary drivers by sudo apt-get install nvidia-current-updates-dev.

share|improve this answer
    
I actually think that I installed it manually from the .run file but I tried the commands and rebooted the computer. The GUI came back but I can strangely enough only log-in with a guest-session. When I try to login with my username and password (which is correct!) the screen turns black and the NVIDIA logo flashes for a short while and then I am back on the log-in screen. –  patlan Jun 2 '12 at 12:51
    
I do get a message for a short second before coming back to the log-in screen: Stopping anac(h)tronistic cron [ok] starting cpu interrups balancing daemon [ok] starting crash report submission daemon [ok] speech-dispatcher disabled: edit /etc/default/speech-dispatcher Stopping save kernel messages [ok] Starting the Winbind daemon windbind saned disabled: edit /etc/default/saned [ok] Starting anac(h)ronostic cron [ok] Stopping system V runlevel compability [ok] –  patlan Jun 2 '12 at 14:04
1  
@Samik I can confirm this solves the issue for me using the packaged binary drivers and kernel 3.2.0.26 –  kynan Jun 27 '12 at 0:33
    
@kynan thanks for the reply. I've edited my answer. –  Samik Jun 27 '12 at 10:40

I searched so much to find this solution. I had driver version 295.40. Actually I was installing latest nvidia driver version 295.59. It installed correctly.

But lightdm didn't load. I reinstlled lightdm and tried so many things.

Finally this command saved the day

sudo apt-get purge nvidia-current

I think Samik(person who replied above) explained the reason that driver version 295.40 did not unistalled correctly and may be that was causing the issue.

Also note that a new driver 302.17 has been released. It fixes a MAJOR SECURITY VULNERABILITY.

However, as of now nvidia site still show 295.59 as latest driver.

you can get 302.17 driver from this page:

http://www.nvidia.com/object/Unix.html

302.17 driver (64 bit): http://www.nvidia.com/object/linux-display-amd64-302.17-driver.html

share|improve this answer

I had the same problem but the Ubuntu kernel version was 304.43 and my Nvidia driver version was 295.49. However, I solved it the same way.

sudo apt-get purge nvidia*

then after the process was complete...

sudo apt-get install nvidia-current-updates-dev

and then, after this process was complete I rebooted and everything worked perfectly!

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.