Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Gnome 3. After upgrading from 11.10 to 12.04, "Ctrl-Alt-S" was reclaimed for use in toggling the shaded state of a window.

I have checked the following places, and I haven't been able to find any instance of a keybinding set for toggling the shaded state.

  • System Settings / Hardware / Keyboard / Shortcuts (as per How do I disable Ctrl+Alt+s to minimize a window?)
    • I even tried setting a different shortcut. Made no difference.
  • dconf-editor (now deprecated, from what I've found)
  • gconf-editor/gsettings

What am I missing?

share|improve this question
2  
This link contains the solution. –  user106500 Nov 8 '12 at 16:55

3 Answers 3

Try the following:

CompizCompiz > General > General Options > Key Bindings > (At the bottom) Toggle Window Shaded

share|improve this answer
    
Incorrect. Compiz settings don't affect GNOME3 (gnome-shell actually). –  jokerdino Jun 12 '12 at 9:36
    
Sorry I'm working in unity (forgot that) –  Sevenearths Jun 12 '12 at 11:55
    
Well, you could delete your answer.. –  jokerdino Jun 12 '12 at 11:58

The trick is to set up a new shortcut for the toggle-shade feature, using dconf-editor. Follow these steps:

  1. Install dconf-editor: sudo apt-get install dconf-tools
  2. Open dconf-editor (Alt-F2, enter dconf-editor)
  3. Expand until the element: org → gnome → desktop → wm → keybindings.
  4. Change the value for the key toggle-shaded to something less intrusive: ['<Control><Super>s']

UPDATE: There is an easier way to do it that does not require dconf-editor:

gsettings set org.gnome.desktop.wm.keybindings toggle-shaded "['<Control><Super>s']"
share|improve this answer

the following:

CompizCompiz > General > General Options > Key Bindings > (At the bottom) Toggle Window Shaded

will work if you install gnome-fall back in ubuntu 12.04

see :- http://ubuntuguide.org/wiki/Ubuntu:Precise#Install_a_classic_Gnome-appearing_User_Interface

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.