Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

i've tried to download XAMPP, untar it in /opt/lampp and launch

sudo ./lamp start

but i get this output:

Starting XAMPP for Linux 1.7.7...
XAMPP: Another web server daemon is already running.
XAMPP: Starting MySQL...
XAMPP: Couldn't start MySQL!
XAMPP: XAMPP-ProFTPD is already running.
XAMPP for Linux started.

so i opened synaptic and i have installed mysql server.

now i have 2 problems, if i restart my ubuntu 10.10:

  1. every time i restart my ubuntu i have to retype

    sudo /etc/init.d/mysql stop

  2. if after stop mysql daemon i relaunch lampp i get same message: XAMPP: Couldn't start MySQL!

/var/log/mysql.err and /var/log/mysql.log are empty..

share|improve this question
This is why I avoid wrappers like xampp, and install Apache, MySQL, and whatever else I need individually. Each of them is easy to install and maintain, but adding another layer around them just makes it more complicated, IMHO. It seems like you already have most of it, so why not use what you have instead of fighting it? – Marty Fried Jun 1 '12 at 17:32
and adding to @MartyFried do not use XAMPP for a production setup. XAMPP has been designed for developers to get on with developing at localhost and not to have the worry about the security mechanics of the server suite and so security has been set in the configuration files as a low priority because the servers have no need to be open to the Internet - your PC firewall correctly configured will block most intruders. – Rinzwind Nov 23 '12 at 13:28
up vote 2 down vote accepted

I've resolved in this way:

sudo chmod -R 777 /opt/lampp
sudo chown -hR nobody /opt/lampp
sudo chmod -R 755 /opt/lampp

then I noticed that I have another mysqld instance running and stoped it with:

sudo service mysql stop
share|improve this answer
Thank you for "sudo service mysql stop". Xampp's mysql couldn't start because there was another mysql daemon running. However, running /etc/init.d/mysql stop seemed to stop and immediately start it up again. Your command worked permanently. – Blossoming_Flower Sep 20 '13 at 0:21
sudo service mysql stop
sudo /opt/lampp/lampp restart

It worked for me.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.