Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to configure my keyboard to write characters like ^ or ~ with just one click. A friend told me, I have to set nodeadkeys somewhere, but not the place. So, where to change this configuration (preferably manually in a .conf file).

What I already tried:

The only seemingly meaningful documentation I found about setting nodeadkeys, was in this German website. This page describes different ways to get through the GUI menus, but all of them don't work on my freshly setup Ubuntu system (with gnome). Maybe it was written for older versions. It also describes how to set it manually in the xorg.conf, which should be found in /etc/X11/, which is also not the case. I looked for an xorg.conf all over the system (sudo find / -name "xorg.conf") but also didn't find anything. No result yet.

share|improve this question
    
Are you on Ubuntu 12.04 or another version? –  serve.chilled Jun 1 '12 at 15:15
    
Yes, and the answer below is working for me. –  erikb Jun 4 '12 at 8:37

1 Answer 1

up vote 3 down vote accepted

Every keyboard layout that uses dead keys by default has a corresponding (eliminate dead keys)-version. To change keyboard layout, go to System Settings > Keyboard Layout and press the +-button to add a new layout.

If, for example, you want a German layout without dead keys, search for "german" in the search field. You should find the option "German (eliminate dead keys)". enter image description here

share|improve this answer
    
Yeah there is a setting in the Keyboard settings dialog for Kubuntu too. –  jippie Jun 1 '12 at 16:14
    
I didn't think about looking into the + menu. Thanks a lot! –  erikb Jun 4 '12 at 8:36

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.