Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My wireless connection doesn't work.

I've tried this Ubuntu documentation on wireless and I've gotten no results . Previously, I've installed Ubuntu 12.04 with VMware and the wireless connection worked.

I have a Dell inspiron laptop Pentium (R) dual core CPU T4500.

share|improve this question
We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Jul 17 '12 at 17:41

It is probably not using some proprietary driver.

  1. Click on the dash, and type "driver".
  2. Click on "Additional Drivers". A window will pop up and ask for your root password.
  3. Then in the next window that pops up. In the first field select the driver that looks something like this: "Broadcom STA wireless driver".
  4. Then at the bottom click "Activate".
  5. Wait for it to download and install then restart your computer and see if it works.
share|improve this answer
Thank you Leinardo but I'cant download drivers because I can't provide an internet connetion. when I click "Activate" it appears a tab that tell's me "no internet connetion". – merjola Jun 1 '12 at 15:37
For use internet needs download driver? it's smartest way... – ubuntufan Jun 1 '12 at 15:39
Oh yeah, I forgot. You will need to plug you computer into your router using an Ethernet cable. – Leinardo Smith Jun 1 '12 at 15:45
ok thank you :) – merjola Jun 1 '12 at 16:07

Problems concerning Dell laptops with Broadcom wireless cards chipsets not being recognized, panicing the kernel and other compatibility issues, happends on a regular basis. The source may be the Broadcom's package/driver called 'bcmwl-kernel-source', which is automaticaly installed by Ubuntu. Check out what I've written at the link below, and also at the links pointed by it, to see if the case described is the same you're experiencing.

At the end, don't forget to give a feedback, rating/commenting this answer/question, and help the Ubuntu Community.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.