Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just bought, installed Sword and Sworcery via the Software Centre.

When I run it, the screen goes black, the cursor changes and then all reverts back to normal.

I found the executable that matches the menu item.

/bin/sh /opt/swordandsworcery/ 

When I run it from the console:

Segmentation fault (core dumped)

My setup:

Linux jem-doxie 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Where to from here? Refund? Or can I do something?

share|improve this question
up vote 3 down vote accepted

I was able to get this working by doing the following:

  • Uninstall from the terminal sudo apt-get remove swordandsworcery-bin
  • Download the deb from the link in the email "Your Humble Bundle order" (received after purchasing the humble bundle)
  • Install the deb from the terminal (it failed from the software centre) with sudo dpkg -i swordandsworcery_1.00-1_amd64.deb

Note, I replaced v1.56 with v1.00 - that may be why it now works.

share|improve this answer
did you have problems with dependencies when installing like this? – Simon B Jun 9 '12 at 16:09
ran apt-get install -f to add 150MB of dependencies and works OK now :) – Simon B Jun 9 '12 at 16:20

I have the same issue and contacted the developers (Capybara Games). They've been very responsive and pointed me to this page. Hopefully, they can get it sorted for the version in the Ubuntu Software Centre so that users don't have to go fiddling with installing a .deb.

By the way, you can find the logs here, they may have a hint as to what's going wrong:

share|improve this answer

I have fixed this problem for several people, and the solution seems to be:

sudo apt-get install libpulse0:i386

I hope this is useful.

share|improve this answer

I know this is an old thread, but I found a fix, at least on my system. I was having the same issue, on Ubuntu 12.10 64-bit with dual monitors, even after I turned one of them off. I went into /opt/swordandsworcery/ and uncommented the SDL line. That got me to the segfault issue. Then I went into ~/.capy/SwordAndSworcery/config.txt and found that the width was set to 3840, which is double my single-monitor resolution (or the total resolution when both monitors are on). Switched that to 1920 and everything loaded fine after that.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.