Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The sound on my machine (Medion Akoya S5610) works intermittently. If I reboot enough times I do get sound. This happened before I upgraded, when running Oneiric too. I have fiddled around with alsa-base.conf, putting in different values for model in options snd-hda-intel model=but still the issue persists (although I get the impression that I am more like to have sound on the next reboot if I have edited that file although I can't be sure of this). Adding index=0 does not help the situation either.

I have been thinking that this problem could be related some how to the order that driver modules are loaded. The snd-hda-intel module is also used for the sound card (ALC888) in my graphics card. Could it be that these are some how competing? If so, how do I add a preference when they are using the same module?

This is the result of lspci -nn | grep Audio (when sound was not working):

00:1b.0 Audio device [0403]: Intel Corporation 82801I (ICH9 Family) HD Audio Controller [8086:293e] (rev 03)
01:00.1 Audio device [0403]: Advanced Micro Devices [AMD] nee ATI RV620 HDMI Audio [Radeon HD 3400 Series] [1002:aa28]

I've been wrestling with this problem for ages and ages and have spent days looking for answers on forums but to no avail so I would appreciate any help you can give.

Many thanks

share|improve this question

1 Answer 1

up vote 1 down vote accepted

I upgraded my kernel up to 3.2.0-26 and now everything works correctly all the time, even after hibernation.

I do have the line options snd-hda-intel model=auto in my /etc/modprobe.d/alsa-base.conf file.

Hope this helps

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.