Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I followed the instructions here http://ubuntuforums.org/showthread.php?t=1974006 about how to solve this issue. It worked for a bit and then stopped. After doing a modprobe I could at least see my network and click on it but it would not connect (I can always see it if I look under the listed wireless networks under VPN Connections, however). I'm thinking, from what I read at least, the issue might be that my wireless switch was on during those first steps. Do I now have to undo the b43 install and do it again? Or is there something else I could try? I just made the switch to Linux yesterday, so I am hesitant at this point to mess with anything on my own. I should note now that it was installed by someone who knows what they are doing, so we are all good on that front.

share|improve this question
    
Hi DanielleN, when you say it worked for a bit did it work for a few hours, days, weeks? Did something change when it stopped working (did you install any packages, updates, etc?) What broadcom adapter do you have? You can find out with lspci | grep Broadcom from the terminal, if you don't already know. Any additional info might help. –  Chris Jun 1 '12 at 7:41
    
It worked until I shut it down for the night, so was probably only working for an hour or less. I think after that we installed the multimedia codecs in one go (again, wasn't me who did it). That was the last thing we did before shutting it down to go to bed. I'm pretty sure now that it was still connected by the ethernet though, which leads me to believe it was doing the same thing it did with me after the modprobe (wireless shows up, but does not actually connect properly). Broadcom Corporation BCM4311 802.11b/g WLAN (rev 01) –  DanielleN Jun 1 '12 at 22:22
    
I have no real answer but maybe a hint. I have the same sort of problem with Inspiron/Broadcom/Ubuntu 12.04. It seems every time I install updates (every few days), the wireless is knocked out. I have to repeat the b43 install. Note that just rebooting is not enough to cause the problem for me. I do that all the time without problem and wireless works each time. In my case it is something to do with the software updater. –  user68102 Jun 3 '12 at 15:17
    
If you want someone to help you troubleshoot, please post the outputs of the following: lspci -nnk | grep -iA2 net, lsmod. Please do not post outputs in the comments section. If you can't edit the question, use pastebin.com, and post a link. It probably also wouldn't hurt getting the firmware from a more reliable source. Try following this howto: help.ubuntu.com/community/WifiDocs/Driver/bcm43xx. –  mikewhatever Jun 3 '12 at 17:47
1  
@DanielleN: I have the same hardware on my laptop and it works without fail on 12.04. It is possible that, like mikewhatever stated above, the firmware you installed is questionable. I would remove them with sudo rm -r /lib/firmware/b43, then hook up with a wired connection and install with sudo apt-get install b43-fwcutter firmware-b43-installer. That basically installs the firmware you tried and sets up everything automatically. If that doesn't work please follow the instructions by mikewhatever above. –  Chris Jun 5 '12 at 1:43

1 Answer 1

I try that solution and it's working.

You need to download the B43.zip install, unzip it into a folder named b43, move the folder in /lib/firmware and do a mobprobe

sudo mobprobe b43

Checkout the link to UbuntuForums for further reference.

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom Dec 1 '12 at 10:20

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.