Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a MicroSD card in a USB adapter (which plugs into a USB port on my machine, and acts like a USB flash drive). I was using Unetbootin to make this a bootable USB flash drive with Kubuntu. But I needed to cancel while it was working. So I killed the Unetbootin process from the console.

Since then, I can't format the MicroSD or delete the folder that Kubuntu made. I have also tried mkdosfs, with no success. I can't mount the drive anymore either? What can I do, to make this drive usable again?

Trying to create a new partition table in GParted, as described in Eliah Kagan's answer, does not work. It fails with the error message "imposible crear tabla de particiones" ("unable to create a partition table").

share|improve this question
    
Have you tried erasing any existing partition information by using sudo dd if=/dev/zero as suggested in the answer from 'izx'? If the dd command is successful then I would recommend you create an MBR (msdos) partition table and a single FAT32 partition using gparted before retrying UNetbootin. (I have experienced problems trying to use multiple partitions on a USB drive. While you are just trying to get this to work it is probably best to start with a very simple setup.) –  irrational John Jun 1 '12 at 20:34

4 Answers 4

This is a bit late, but here's my input.

My brother somehow made his flash drive not work on Windows and read-only in Linux. Trying to use GParted to make a new partition table didn't work, so I tried the dd option. This didn't work either, but after a bit of fiddling I used the following command:

sudo dd if=/dev/zero of=/dev/sdb bs=1M count=40

After this I could use GParted again, and it worked perfectly. Obviously the first block was not the problem, but the problem lay somewhere between there and block 40.

share|improve this answer
    
You could do the same with the Disk Utility (I mean formatting that card and creating whatever partitions and file systems ) –  user85164 Nov 5 '13 at 4:30

Install the gparted package in the Software Center (or in the Terminal/Konsole by running sudo apt-get update followed by sudo apt-get install gparted). This gives you the GParted Partition Editor.

Then run GParted. Find the MicroSD/USB drive in the list of devices in the drop-down menu at the upper-right corner of the screen. Make sure you have the right device. (You can look at its size to help gauge this.) It would be very bad if you accidentally formatted a different drive that had valuable data, or your Ubuntu system, on it!

With the correct device selected, run Device... > Create Partition Table.... Use the default options (i.e., just click Apply, don't change the option under Advanced). Please note that, while other modifications in GParted are only performed when you apply your changes, creating a new partition table wipes out anything on the drive on which it is done, and is performed immediately when you click Apply.

Now create a FAT32 partition on the device (or a FAT16 partition if it is very small, like just a few megabytes, or if you know you need a FAT16 partition, for example, because you are following directions that call for a FAT16 partition). The new FAT32 partition should cover the whole drive (which is the default in GParted). You'll see the partition there, but that's just showing you what it will look like when you apply your changes.

Then apply your changes (by clicking the green check mark). Quit GParted.

You should be able to find the new partition in any Nautilus (i.e., file browser) window, under Devices on the left. Mount the partition by clicking on it under Devices in Nautilus.

Now you should be able to write to it with UNetbootin.

share|improve this answer
    
thanks but i have already tried with gparted and nothing –  Mauri Olivares Jun 1 '12 at 1:54
    
i tried (well i have 2 primary partitions in the usb of fat 32)i tried to delete,move,resise,formating to another format and nothing (at the both partitions) and the error it's always the same the tool is no avaible in this moment (or something like that i am translating from spanish by myself sorry) –  Mauri Olivares Jun 1 '12 at 2:02
    
ok but i have already try do a partition table or "tabla de particiones" and the error is unable to create a partition table" or "imposible crear tabla de particiones" and just that and botton of "ok" –  Mauri Olivares Jun 1 '12 at 2:06
    
@MauriOlivares Ah, I see. Sorry, I didn't realize the error message was in response to this. I've just edited that information into your question--that should help others to offer solutions to your problem (in case I don't come up with anything, or someone else has a solution for you first). –  Eliah Kagan Jun 1 '12 at 2:09
    
ok thanks =) for that –  Mauri Olivares Jun 1 '12 at 2:15

Unmount the usb drive first and then format it with GParted.

share|improve this answer
    
+1 Thanks a lot for the answer. –  gotqn May 2 at 19:02

I just tested it on my Linux, you should use Disk Utility. (System > Administration > Disk Utility)

  1. Click on unmount volume if it mounted. If an error arise, try to unmount it from the Desktop, if still an error arise, then remove it and plug it in again.
  2. Click on format drive and leave the default. (it is master boot record)
  3. After finishing deleting, click on Create partition and choose NTFS and leave the default.

This steps I tested myself, please if there is anything else, tell me.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.