Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
I can't add PPA repositories!

When I typed this command in the terminal:

sudo add-apt-repository ppa:noobslab/icons

I got the following error. Please help.

Traceback (most recent call last):   
  File "/usr/bin/add-apt-repository", line 125, in <module>
    ppa_info = get_ppa_info_from_lp(user, ppa_name)
  File "/usr/lib/python2.7/dist-packages/softwareproperties/ppa.py", line 80, in get_ppa_info_from_lp
    curl.perform()
pycurl.error: (7, "couldn't connect to host")
share|improve this question

marked as duplicate by jokerdino, Ringtail, RolandiXor, Eliah Kagan, Mitch Sep 29 '12 at 7:43

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

3 Answers 3

The output says "couldn't connect to host". Try making sure that you are connected to the internet and can reach the ppa server. You can also add the following line to /etc/apt/sources.list: deb http://ppa.launchpad.net/noobslab/icons/ubuntu YOUR_UBUNTU_VERSION_HERE main

share|improve this answer
    
For example: deb ppa.launchpad.net/eugenesan/java/ubuntu precise main –  YumYumYum Oct 17 '13 at 2:37

Enter the following:

sudo update-ca-certificates

This will fix the issue

share|improve this answer

You can still add PPA through Synaptic Package Manager.

  1. Open Synaptic Package Manager.

    Step-1

  2. Go to Settings > Repositories > Other Software > Add

    Step-2

  3. Now add the PPA

    Step 3

  4. Reload to apply changes.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.