Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So, I've given up trying to configure my system (ubuntu 10.10, open source ATI drivers) to shutdown/logout/restart gracefully. Whenever I do any of the three, all I get is an ugly ubuntu logo with console text running over it. It does shutdown quickly, and I love that. It just looks awful while it does it.

Is there a way to just have nothing displayed when I click shutdown/logout/restart? For example, is there a command that can disable the screen that I can put somewhere in some configuration file that will be the absolute first thing that is executed when I select shutdown/logout/restart? I know of the xset dpms force off command which does turn the display off, but moving the mouse at all or pressing any key will turn it back on again.

Is there a command that can disable the screen and disable any input that I can place somewhere that will be the first thing that is executed when I select shutdown/logout/restart?

share|improve this question
    
with you on that one buddy. i think it's a bug in the order of shutdown processes. plymouth splash on shutdown worked on and off for me in 10.04 (using closed source drivers) but it's toast in 10.10. I can't complain though as I am not using the open drivers –  hbdgaf Nov 23 '10 at 5:00
    
Please include information about your video devices and we can see if it's a know bug. Do it into a terminal lspci -vv | egrep '(VGA compatible controller)|(Display controller)' and paste into paste.ubuntu.com –  crncosta Nov 24 '10 at 14:59
add comment

3 Answers

ok to clarify that, when you startup (from power off or restart), is the splash screen in your native resolution?

Also, do you have any new/mainline kernels installed? I mean those that are NOT rolled out as part of ubuntu update.

I use the proprietary nvidia drivers and that messed my start and shutdown screens. I did find a workaround so that the screen now just works like the one with the open source nouveau drivers. Keen on that? Involved editing some grub header files.

share|improve this answer
2  
Should this not have posted as a comment rather an answer? –  Roddie Nov 24 '10 at 11:08
    
He doesn't have enough rep to comment. –  Jeremy Nov 25 '10 at 4:53
add comment

Okay, I don't see a reply button to anyone's comments above so I guess I'll just have to post this here:

@aking1012: I put the information you requested here. Again, I'm only using the default ubuntu drivers (though, I did try the proprietary drivers earlier to try and resolve the issue but it changed nothing).

@Eshwar: It is not a resolution problem. The bootup splash is fine, displays in the correct resolution and does not display any terminal text. The shutdown/logout/restart text is also in the correct resolution. Also, I only have the kernels that ubuntu provides through regular updates.

@Fraekkert: Thank you, but that is the complete opposite of the solution I'm looking for. Getting rid of Plymouth would give me a verbose bootup, as well as, shutdown/logout/restart. Terminal text is what I'm trying to avoid.

share|improve this answer
    
@Steven The way you reply to peoples questions here is to directly edit your question to make it better and more detailed, they will then revise their answers. Feel free to update your question and just delete this answer. See here: meta.askubuntu.com/questions/257/how-does-ask-ubuntu-work –  Jorge Castro Nov 25 '10 at 16:05
add comment

I guess you could try to disable Plymouth, or to change the theme. There's an easy tool for that here.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.