Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm actually trying to upgrade my Ubuntu 11.04 server to 12.04, but I have to go through 11.10 first, right? Well, do-release-upgrade is failing miserably. Here is the output, with duplicate lines and such removed (still > 1500 lines): http://paste.ubuntu.com/1018546/

Yeah. I found this question, which seems to mention similar errors, but I've tried all of the suggestions given there and nothing has changed.

I tried running apt-get dist-upgrade; it churned for a while and eventually came back with "Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?" Ran apt-get update and got much the same kinds of error messages I got from do-release-upgrade.

The following are samples of the outputs that raise my eyebrow (line numbers reference the pastebin code):

  • Ign http://us.archive.ubuntu.com natty InRelease (e.g. line 43)--don't know if this is a problem or not, but it shows up frequently
  • Err http://security.ubuntu.com natty-security/restricted amd64 Packages (e.g. line 101)
  • bzip2: (stdin) is not a bzip2 file. (e.g. line 117)
  • 404 Not Found [IP: 91.189.92.167 80] (e.g. line 199)--when this occurs, it always occurs after one of the Err lines
  • Updating repository information WARNING: Failed to read mirror file (e.g. lines 580-81)
  • E.g. lines 1045-52:

    bzip2: Data integrity error when decompressing.
    Input file = (stdin), output file = (stdout)
    
    It is possible that the compressed file(s) have become corrupted.
    You can use the -tvv option to test integrity of such files.
    
    You can use the `bzip2recover' program to attempt to recover
    data from undamaged sections of corrupted files.
    

And the summary of the whole train wreck can be found in lines 1520-65.

Any ideas/suggestions/solutions? (The bzip2 errors particularly confuse me. It looks like it's trying to decompress from stdin? Is it supposed to do that?) Should I try downloading & upgrading from the ISO instead? (Edit: ISO upgrade failed too.) I'm glad to provide any further information I've forgotten. TIA!

share|improve this question
    
To provide text in your question (or for very long text, at paste.ubuntu.com) that would make it easier for people to help you, you might consider attempting the upgrade again, using script to record everything on the command-line, perhaps in conjunction with pastebinit. –  Eliah Kagan May 31 '12 at 22:31
    
Thanks for the tip--running it again with script right now. –  DLosc Jun 1 '12 at 19:48

1 Answer 1

up vote 0 down vote accepted

My upgrade to 11.10 finally worked! Here's the post-mortem:

Over the weekend, I did some more searching for similar problems--specifically 404 errors while upgrading. This page among others suggested that it might just be a temporary problem with the mirror site. Okay, I thought, I'll try changing mirrors when I get in on Monday.

The first thing I tried to do Monday was install a software package. It failed, of course--this problem affects apt-get just as much as do-release-upgrade. Just for kicks, I ran apt-get update again, just to watch it fail--but this time it succeeded. I was able to install my package. Next I ran apt-get dist-upgrade; it still had some errors, but fewer than before. So today, I tried the do-release-upgrade--and it worked. Hooray!

FINAL DIAGNOSIS: Temporary problems with the mirror site(s)--either us.archive.ubuntu.com, or security.ubuntu.com, or both. It's also possible I had transient network issues, although I think that's less likely.

RECOMMENDED SOLUTION: Wait a couple weeks and try again. If that doesn't work, switch mirrors. (See the list of archive mirrors. I'm sure there are good online tutorials for how to switch, though I'm too lazy to look them up right now).

Hope this helps somebody. Now I'm off to see if I can get the upgrade to 12.04 to work! =^P

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.