Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Inevitably, I've coughed up for the latest Humble Bundle, containing 5 games: Amnesia, Bastion, Limbo, Psychonauts and Superbrothers: Sword and Sorcery. At the download page it says download for ubuntu but after that it transpired (after much head scratching) that the three games it lists "are not available for your version of ubuntu".

The other two, Bastion and Psychonauts "will appear on the page soon", but until then does anybody think they might work? I don't want to to be disappointed after downloading a 4gb file, causing me to reminisce on childhood memories of loading 8-bit tape games for 45 minutes only to find out that you had to reload them once you died after 30 seconds in.

share|improve this question
    
support.humblebundle.com/customer/portal/articles/… says that Superbrothers requires 10.10, so that's out. –  daithib8 May 31 '12 at 20:45
add comment

4 Answers

up vote 3 down vote accepted

On the download page, Amnesia and Bastion have .sh downloads, Limbo and Superbrothers have .tar.gz downloads, and Psychonauts has a .zip. All of those are most likely statically linked and shouldn't depend hugely on a specific version of linux.

That doesn't mean they will necessarily work, but it is pretty good odds that they ship with everything they need.

share|improve this answer
add comment

Despite indicating the contrary, Superbrothers works just fine on 10.04. Don't bother with the deb file, as it won't install. Just grab the tar.gz of it, unpack it somewhere, and execute the run.sh script - plays perfectly.

share|improve this answer
add comment

Don't they include tar balls, or sh install scripts too? All my past Humble Bundle purchases included those, all well as .debs. I'd just install it from the tar ball.

share|improve this answer
add comment

I installed bastion from the .sh file, and it did not work. A second try with USC ( Ubuntu software center ) worked fine. I am using ubuntu 12.04.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.