Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have an Alienware M15x with the following specs

Intel Core i7 920M Ati 5870M 500GB HD 4GB RAM

I've been running Ubuntu for a while on my work computer with an second generation i3, 8gb ram and a 500gb HD and without a video card without problems for months now.

But on my laptop it lags alot. I installed the ATi drivers from the website. But when I look in my system details it says:

Graphics: VESA: BROADWAY

Shouldn't it show my 5870M?

share|improve this question

1 Answer 1

up vote 0 down vote accepted

Did you ever seen a popup like this one? This is the easy way to install proprietary video drivers (I have nVidia but the procedure should be the same). Otherwise you can try the official Ubuntu page that also explains how to install Catalyst drivers. Finally, you can also look at this thread: the command line tool to call the "restricted drivers" window from the shell should be jockey-text.

share|improve this answer
    
Yes I installed them right away. Than I downloaded the drivers from ATi website. When I downloaded them and tried to install it told me to uninstall the old drivers first. Then I installed the newly downloaded. They didn't work so I installed the restricted drivers again, I have the feeling it is better now, but I will read the official Ubuntu page you gave me. Thanks alot :) –  Martijn Buurman Jun 1 '12 at 6:42

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.