Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use the Purisa Medium font in various appearance settings, it's wonderful. However, whenever I type the characters T and M next to each other, they mysteriously change into a face-like character that I have never seen elsewhere. Sadly, askubuntu doesn't allow me to post an image, but the same issue was reported here, with images: http://forum.ubuntu-fr.org/viewtopic.php?id=344298

Any ideas would be much appreciated!

share|improve this question
    
There is a clear img button in the toolbar of the composer. You have click that and show path to image and click "upload". –  Mussnoon Nov 23 '10 at 1:20
    
@Mussnoon, @user6423 did not have enough rep (10) at the time he posted this question. He can add images now though. –  Alvin Row Nov 23 '10 at 1:48
    
Oh...never knew you needed rep to post images. Makes sense now that I think of it though. –  Mussnoon Nov 23 '10 at 1:57
    
Are you using Purisa as one of your your system fonts? (As in System → Settings → Appearance → Fonts ...) –  Stefano Palazzo Nov 23 '10 at 7:06
add comment

1 Answer

up vote 3 down vote accepted

A font can contain tables which instruct it to replace certain combinations of characters with a glyph that represents them written together as a ligature. You won't come across it that often, and might not have noticed when you have. The image below is an example of this with the Tekton Pro font with the letters "ff" together and separated by a space. Note the ff is a glyph with one continuous line. If it were two normal f glyphs, that line would be staggered.

alt text

For some reason the Purisa font has such a substitution for "TM", replacing it with an entirely different glyph. This may be a designer's signature or some such whim. As it is primarily designed for writing Thai, perhaps TM wasn't thought a likely combination for someone to want to type.

This is a version of the font that I have edited in fontforge, and removed the instruction to substitute TM. You could use this to replace /usr/share/fonts/truetype/thai/purissa.ttf as a quick fix (after replacing the file you need to run fc-cache -r and might need to log out if you are using it as a system font). I've filed as a bug.

share|improve this answer
    
Thank you @misterben, that was a very useful explanation, and the fix worked. –  MrMartin Nov 24 '10 at 14:06
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.