Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I decided it was time to update my ubuntu (single boot) computer from 64-bit v10.04 to 64-bit v12.04. Unfortunately, for some reason (or reasons) I just can't make it work.

Note that I am attempting a fresh install of 64-bit v12.04 onto a new 3TB hard disk, not an upgrade of the 1TB hard disk that contains my working 64-bit v10.04 installation. To perform the attempted install of v12.04 I unplug the SATA cable from the 1TB drive and plug it into the 3TB drive (to avoid risking damage to my working v10.04 installation).

I downloaded the ubuntu 64-bit v12.04 install DVD ISO file (~1.6 GB) from the ubuntu releases webpage and burned it onto a DVD. I have downloaded the DVD ISO file 3 times and burned 3 of these installation DVDs (twice with v10.04 and once with my winxp64 system), but none of them work. I run the "check disk" on the DVDs at the beginning of the installation process to assure the DVD is valid.

When installation completes and the system boots the 3TB drive, it reports "unknown filesystem". After installation on the 250GB drives, the system boots up fine.

During every install I plug the same SATA cable (sda) into only one disk drive (the 3TB or one of the 250GB drives) and leave the other disk drives unconnected (for simplicity).

It is my understanding that 64-bit ubuntu (and 64-bit linux in general) has no problem with 3TB disk drives. In the BIOS I have tried having EFI set to "enabled" and "auto" with no apparent difference (no success). I never bothered setting the BIOS to "non-EFI".

I have tried partitioning the drive in a few ways to see if that makes a difference, but so far it has not mattered. Typically I manually create partitions something like this:

8GB  /boot  ext4
8GB  swap
3TB  /      ext4

But I've also tried the following, just in case it matters:

  8GB  boot   efi
  8GB  swap
  8GB  /boot  ext4
  3TB  /      ext4

Note: In the partition dialog I specify bootup on the same drive I am partitioning and installing ubuntu v12.04 onto. It is a VERY DANGEROUS FACT that the default for this always comes up with the wrong drive (some other drive, generally the external drive). Unless I'm stupid or misunderstanding something, this is very wrong and very dangerous default behavior.

Note: If I connect the SATA cable to the 1TB drive that has been my ubuntu 64-bit v10.04 system drive for the past 2 years, it boots up and runs fine.

I guess there must be a log file somewhere, and maybe it gives some hints as to what the problem is. I should be able to boot off the 1TB drive with the 3TB drive connected as a secondary (non-boot) drive and get the log file, assuming there is one and someone tells me the name (and where to find it if the name is very generic).

After installation on the 3TB drive completes and the system reboots, the following prints out on a black screen:

Loading Operating System ...
Boot from CD/DVD :
Boot from CD/DVD :
error: unknown filesystem
grub rescue>

Note: I have two DVD burners in the system, hence the duplicate line above.

Note: I install and boot 64-bit ubuntu v12.04 on both of my 250GB in this same system, but still cannot make the 3TB drive boot.

Sigh. Any ideas?

==========

motherboard == gigabyte 990FXA-UD7
CPU == AMD FX-8150 8-core bulldozer @ 3.6 GHz
RAM == 8GB of DDR3 in 2 sticks (matched pair)
HDD == seagate 3TB SATA3 @ 7200 rpm (new install 64-bit v12.04 FAILS)
HDD == seagate 1TB SATA3 @ 7200 rpm (64-bit v10.04 WORKS for two years)
HDD == seagate 250GB SATA2 @ 7200 rpm (new install 64-bit v12.04 WORKS)
HDD == seagate 250GB SATA2 @ 7200 rpm (new install 64-bit v12.04 WORKS)
GPU == nvidia GTX-285
??? == no overclocking or other funky business
USB == external seagate 2TB HDD for making backups
DVD == one bluray burner (SATA)
DVD == one DVD burner (SATA)

64-bit ubuntu v10.04 has booted and run fine on the seagate 1TB drive for 2 years.

share|improve this question
    
Are you creating one 3TB partition? –  Mitch May 31 '12 at 17:46
    
No, I create: one 8GB /boot partition, one 8GB swap partition, one 3TB / partition. See the original message for partitions attempted (all fail the same way). –  honestann May 31 '12 at 19:10
1  
If you want to use all the space on your 3TB drive, you will need to use a GUID Partition Table (GPT) on it. (You could use MBR, but you'll only be able to access the first ~2048 GB of the drive). My understanding is you can boot a GPT partitioned drive using in either legacy BIOS mode or UEFI, but different approaches are used for each. If you use legacy BIOS to boot, then I think you will be unable to also install Windows 7 since Windows will only boot from a GPT drive if you are using UEFI. So ... which way do want to try to go with your install? GPT & legacy BIOS or GPT & UEFI? –  irrational John Jun 1 '12 at 1:09
    
You might want to also look at Rod Smith's answers to questions about installing Ubuntu. He seems to be much better informed about using GPT and/or UEFI than many of us here. (CC: @RodSmith) –  irrational John Jun 1 '12 at 1:13
add comment

3 Answers

Since you can't install onto any drive, the 3TB drive is just complicating the issue. Ignore that drive for now, get things working on the 250GB drive first, then try the 3TB drive.

Boot into a working OS, connect and mount the 250GB drive, and look at the logs in /var/log from the mounted drive. That's where the other logs are at in most flavors of Ubuntu, so the installation logs should be there, too.

share|improve this answer
    
And what should I do with the log file? Post it here, or what? I assume it is a rather long file. Also, the error booting the 250GB drives (grub error 15) is different than the error booting the 3TB drive (unknown filesystem)... so I'm not sure solving the problem on the 250GB will help with the 3TB. –  honestann May 31 '12 at 18:32
    
You could always post the contents of the log to a pastebin such as paste.ubuntu.com and then post the URL (link) to your pastebin so others can review the information in it. It is usually better to directly include only pertinent excerpts from the logs in your question details. (Cuts down on the clutter.) –  irrational John Jun 1 '12 at 1:31
    
Thanks for the pastebin information. –  honestann Jun 2 '12 at 21:59
    
I can now install and boot the 250GB drives fine. So the problem is installing, partitioning or booting the 3TB drive. This implies the problem is something to do with EFI and/or GPT. Remember, this is the simplest possible case --- a fresh install of a single-boot 64-bit ubuntu 12.04 system. –  honestann Jun 2 '12 at 22:02
add comment

I`m going to go out on a limb here.

There is a GUID partition table (GPT) that needs to be implemented, for the master boot record. Current master boot record partitions are limited to 2.1TB, so a new GPT partition table would also need to be used to see beyond this. Of course, this is all fine if you’re using a 3TB drive as a secondary disk, but there are more problems to overcome if you want to use that 3TB drive to boot your OS. Unfortunately, the master boot record is a key part of the standard BIOS setup that motherboards have used for decades.   Now that being said, Ubuntu 11.04 and 11.10 have a serious bug that causes it to erase any existing ESP, thus wiping out any existing boot loaders or other files installed there. Thankfully, this bug has been fixed in Ubuntu 12.04.

I would recommend that you take a look At this site for better understanding about UEFI booting.

Let me know if that works for you.

share|improve this answer
    
Is ESP a reference to the EFI System Partition used on a GPT drive which boots using UEFI? –  irrational John Jun 1 '12 at 1:23
    
The EFI specification includes an EFI System Partition (ESP) as a storage place for EFI boot loaders, drivers, and other files. Thus, if you intend to boot a disk using an EFI-based computer, you should create an ESP. –  Mitch Jun 1 '12 at 5:34
    
Yes, you need an ESP if your computer is using UEFI to boot. But my understanding is that if your computer supports UEFI but is booting a GPT partitioned drive by emulating a legacy BIOS then you would not have an ESP. You would instead need a BIOS Boot partition on the GPT drive. (They have different GUID partition IDs) Of course, if your computer just has a legacy BIOS (no UEFI) this is also what is needed for it to boot a GPT drive. –  irrational John Jun 1 '12 at 5:45
add comment

Boot the DVD as Live Ubuntu,the easiest tool i know to do this is GParted.

At the Gparted search for your 3 TB drive,and make new partition table "Create New Partition Table",when a new window appear asking for the partition table type,click the ms-dos and choose gpt.OK..... Apply.... done.... then install your 64-bit Ubuntu.

easy isn't it ? :)

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.