Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I connect my phone with memory card in it with usb cable to my ubuntu notebook

DBus error org.gtk.Private.RemoteVolumeMonitor.NotFound: The given volume was not found
error message is shown and following is written to the syslog:

May 31 18:29:42 edbwp400322 kernel: [184240.427259] usb 2-1.1: new high-speed USB device number 6 using ehci_hcd
May 31 18:29:42 edbwp400322 kernel: [184240.524759] scsi10 : usb-storage 2-1.1:1.0
May 31 18:29:42 edbwp400322 mtp-probe: checking bus 2, device 6: "/sys/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1"
May 31 18:29:42 edbwp400322 mtp-probe: bus: 2, device: 6 was not an MTP device
May 31 18:29:43 edbwp400322 kernel: [184241.522802] scsi 10:0:0:0: Direct-Access     Samsung  GT-B2710-CARD    2.31 PQ: 0 ANSI: 2
May 31 18:29:43 edbwp400322 kernel: [184241.524147] sd 10:0:0:0: Attached scsi generic sg2 type 0
May 31 18:29:43 edbwp400322 kernel: [184241.525184] sd 10:0:0:0: [sdb] 3911680 512-byte logical blocks: (2.00 GB/1.86 GiB)
May 31 18:29:43 edbwp400322 kernel: [184241.526410] sd 10:0:0:0: [sdb] Write Protect is off
May 31 18:29:43 edbwp400322 kernel: [184241.526413] sd 10:0:0:0: [sdb] Mode Sense: 0f 0e 00 00
May 31 18:29:43 edbwp400322 kernel: [184241.527125] sd 10:0:0:0: [sdb] Write cache: enabled, read cache: enabled, doesn't support DPO or FUA
May 31 18:29:43 edbwp400322 kernel: [184241.536461]  sdb: sdb1
May 31 18:29:43 edbwp400322 kernel: [184241.541653] sd 10:0:0:0: [sdb] Attached SCSI removable disk
May 31 18:29:44 edbwp400322 usb_modeswitch: switching device 04e8:f000 on 002/006
May 31 18:29:44 edbwp400322 kernel: [184242.332659] sd 10:0:0:0: [sdb] Synchronizing SCSI cache

Is there any chance to access phone's memory card as memory stick?

Best regards, Eugene.

share|improve this question
add comment

1 Answer

up vote 2 down vote accepted

The answer is here:

This is a problem with the usb-modeswitch, if you disable it in /etc/usb_modeswitch.conf => DisableSwitching=1 then it works.

share|improve this answer
    
Welcome to AskUbuntu! Whilst the link may answer the question, it would be preferable to add details of the answer here in case the link expires/changes. –  Oyibo Oct 28 '12 at 14:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.