Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a laptop with Ubuntu 12.04 LTS installed as the main OS. The other day I installed Ubuntu-Studio (version 12.04) into another partition on the machine.

The installation went great and when the machine booted, the grub menu popped up and I could see the option for Ubuntu Studio and the vanilla Ubuntu OS'. The problem was that this version of grub, installed by the Studio installer, didn't look great and insisted on putting Studio at the top of the list, and therefore as the main OS to boot.

I use the standard Ubuntu more often, so I booted into that and ran sudo grub-install dev/sda. That worked OK and now Ubuntu boots as normal. Only problem is that the Grub menu doesn't show up and doesn't give me a chance to choose the other OS. Running sudo os-prober shows that it can find ubuntu studio, it doesn't give me a chance to boot it.

Any ideas as to how I can fix this problem?

Cheers in advance.

EDIT: followed instructions here and saw the boot menu, but the only boot options present were for the standard installation of Ubuntu.

share|improve this question
    
I think this is what you're looking for. –  Avio May 31 '12 at 15:35
    
I followed those instructions, but grub only showed boot choices for the standard ubuntu installation... I'll add that to the question. Thanks for that though! –  jackweirdy May 31 '12 at 15:44
    
Do you mean that you see exactly one row, say "Ubuntu 12.04 LTS" or that you see 2 rows, with the first similar to "Ubuntu 12.04 LTS" and the second similar to "Previous Linux versions" or "Advanced options for [...]"? –  Avio May 31 '12 at 15:51
    
Ok, but the os-prober is executed when you type sudo update-grub (e.g. as in this screenshot) or not? –  Avio May 31 '12 at 15:55
    
turns out it wasn't; I had to chmod the /etc/grub.d/30_os-prober file to be executable. Thanks All! –  jackweirdy May 31 '12 at 16:02
add comment

2 Answers

up vote 4 down vote accepted

I the os-prober utility wasn't executable. I had to run this:

sudo chmod +x /etc/init.d/30_os-prober

and then

sudo update-grub2
share|improve this answer
add comment

You just need to run sudo update-grub.

share|improve this answer
    
Already done that several times with no success. –  jackweirdy May 31 '12 at 15:40
    
@jackweirdy, just because you somehow managed to disable os-prober doesn't make the answer a bad one. You still needed to run update-grub. –  psusi May 31 '12 at 18:23
    
I didn't downvote you if that's what you're thinking? –  jackweirdy May 31 '12 at 21:45
    
@jackweirdy, oh... then I'm left wondering who did and why. –  psusi May 31 '12 at 22:05
    
@psusi I also didn't downvote you, but the possible reason may be, sudo update-grub can do nothing with the actual problem of not-recognizing other installation. yes, You're still correct that, he need that command though. –  Anwar Shah Jul 31 '12 at 6:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.