Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Right now I've downloaded an excel project with .csv format, but when I open it[Excel Under Wine], texts are not normal, It's a screenshot of texts:

enter image description here

I think it's unicode problem, How can I fix it?

Any help would be great.

Regards.

share|improve this question
    
Why don't you use OpenOffice/LibreOffice? –  user unknown May 31 '12 at 15:27
    
They don't open this format fine, texts' position is not correct. –  Mahdi May 31 '12 at 15:32
1  
And that file works fine as CSV in Windows? It doesn't look much as CSV and I never had problems using CSV with OpenOffice. Which language is it? Maybe the wrong font? Which character encoding? –  user unknown May 31 '12 at 15:36
    
It works in Windows, It's persian[Farsi] and I dont think it's because wrong font, even if I Change it's font it wont get fixed. Don't know about it's encoding. but I know UTF-8 works fine with persian. –  Mahdi May 31 '12 at 15:48
1  
Ahh I finaly fixed it, Will add answer. –  Mahdi May 31 '12 at 16:25
add comment

1 Answer

up vote 1 down vote accepted

I found a way to fix it and that was it :

In Excel I went to Data Tab and selected ' From Text '.

Steps were like this: 1. Importing file with ' From Text ' Option. enter image description here 2. Changing Unicode to UTF-8. enter image description here And...

enter image description here

enter image description here

It worked with CSV fine, Hope it helps.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.