Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I try to ping or browse using a web browser certain domains names that we host on our local network, it does not work. Yet dig, nslookup correctly return their details. What do I need to do to fix this.

The dns server and dhcp server at our local network work fine on the windows clients.

$ ping ns1.domain.local
ping: unknown host ns1.domain.local
aaron@aaron-laptop:~
$ nslookup ns1.domain.local
Server:     127.0.0.1
Address:    127.0.0.1#53

Name:   ns1.domain.local
Address: 172.16.0.254

$ cat /etc/resolv.conf 
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
#     DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 127.0.0.1
search domain.local

$ nm-tool 

NetworkManager Tool

State: connected (global)

- Device: eth0  [Wired connection 1] -------------------------------------------

  IPv4 Settings:
    Address:         172.16.0.93
    Prefix:          24 (255.255.255.0)
    Gateway:         172.16.0.2

    DNS:             172.16.0.254

Added additional info

As per http://askubuntu.com/a/146310/10998

For some reason avahi-daemon interferes with name resolver

ping ns1
PING ns1.domain.local (172.16.0.254) 56(84) bytes of data.
64 bytes from ns1.domain.local (172.16.0.254): icmp_req=1 ttl=64 time=0.381 ms

share|improve this question
add comment

2 Answers

up vote 1 down vote accepted

edit the /etc/nsswitch.conf file.

cat /etc/nsswitch.conf 
...
#hosts:          files mdns4_minimal [NOTFOUND=return] dns mdns4
hosts:          files mdns4_minimal dns [NOTFOUND=return] mdns4
...

That change fixed it for me, mdns is a particular implementation of dns services which is meant to be faster then dns. It does not resolve the names correctly and with the [NOTFOUND=return] option standard dns is never used. This works fine for most of the internet at large but for some reason is not working for our office resolutions.

By changing the resolution too include dns, I can now ping the domain controller as I expected. As well as the other services we are running on our local office domain.

ping ns1.bidorbuy.local
PING ns1.domain.local (172.16.0.254) 56(84) bytes of data.
64 bytes from controler.domain.local (172.16.0.254): icmp_req=1 ttl=64 time=0.394 ms

ping office-blog.domain.local
PING officewebserver.domain.local (172.16.0.252) 56(84) bytes of data.
64 bytes from officewebserver.domain.local (172.16.0.252): icmp_req=1 ttl=64 time=0.914 ms
share|improve this answer
add comment

You can try to disable avahi-daemon. For some reason avahi-daemon interferes with name resolver. A side effect for me was that if you ping ns1, it works but if you try to use FQDN it does not.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.