Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've made some changes to my compiz with compizConfig settings manager, like enable the cubic desktop and changing the unity icons size.

Today when I started my laptop, they all where gone back to default and I can't even change it back. I mean when I change them in compizConfig, they are not changed in reality, no effects.

I've restarted once, and no effect. Also updated and upgraded packages. compiz --replace and unity --reset didn't work.

And yesterday I installed cheese and gparted. Maybe it was because of that. And this is the first time in my life I'm seeing this.

My question is very similar to this . Had a look at the bugs in compiz launchpad, didn't find anything matching.

Some info about my laptop:

alfred@alFitop:~$ uname -a
Linux alFitop 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

alfred@alFitop:~$ compiz --version
Compiz 0.9.7.8

alfred@alFitop:~$ unity --version
unity 5.12.0

alfred@alFitop:~$ Xorg -version
X.Org X Server 1.11.3
Release Date: 2011-12-16
X Protocol Version 11, Revision 0
Build Operating System: Linux 2.6.24-31-server x86_64 Ubuntu
Current Operating System: Linux alFitop 3.2.0-24-generic #39-Ubuntu SMP Mon May 21 16:52:17 UTC 2012 x86_64
Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.2.0-24-generic root=UUID=404922f4-7e8b-42a4-b009-a03aabb8aa24 ro quiet splash vt.handoff=7
Build Date: 07 May 2012  11:43:21PM
xorg-server 2:1.11.4-0ubuntu10.2 (For technical support please see http://www.ubuntu.com/support) 
Current version of pixman: 0.24.4
    Before reporting problems, check http://wiki.x.org
    to make sure that you have the latest version.

alfred@alFitop:~$ lspci -nnk | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Core Processor Integrated Graphics Controller [8086:0046] (rev 12)

alfred@alFitop:~$ sudo lshw -C Video
  *-display               
       description: VGA compatible controller
       product: Core Processor Integrated Graphics Controller
       vendor: Intel Corporation
       physical id: 2
       bus info: pci@0000:00:02.0
       version: 12
       width: 64 bits
       clock: 33MHz
       capabilities: msi pm vga_controller bus_master cap_list rom
       configuration: driver=i915 latency=0
       resources: irq:41 memory:f0000000-f03fffff memory:d0000000-dfffffff ioport:1800(size=8)

(I wasn't sure what to put, if you think any of the info is unnecessary, feel free to edit and remove that part and save other's time :D )

share|improve this question

closed as off-topic by Paranoid Panda, karel, Eric Carvalho, David Foerster, Anwar Shah May 24 '15 at 7:33

This question appears to be off-topic. The users who voted to close gave this specific reason:

  • "This describes a problem that can't be reproduced that seemingly went away on its own or was only relevant to a very specific period of time. It's off-topic as it's unlikely to help future readers." – Paranoid Panda, karel, Eric Carvalho, David Foerster, Anwar Shah
If this question can be reworded to fit the rules in the help center, please edit the question.

    
I don't have this problem anymore, made a clean install. – Farid Nouri Neshat Jun 11 '12 at 14:39

Most of that info is useful. I just now hit something similar after accepting automatic updates. Not sure exactly what was in the list of packages updated.

I finally fixed the problem via unity --reset. In other words login under Unity, then ctrl-alt-f6 to get to a terminal, log in, and run unity --reset.

I dislike the solution because I am left not knowing which of the many settings needed to be tickled. But sometimes it's better just to start from scratch and apply your tweaks forward.

Here's the article I read that convinced me to try it: Unity doesn't load, no Launcher, no Dash appears

Not sure if it will help your situation, but I was in exactly the same situation.

HTH

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.