Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've been using Linux for five years. A week ago, installed ubuntu 10.10 (2.6.35-22-generic), after the update found that the mode of suspend and hibernate do not work now, still looking for a solution to this problem. Here is the configuration of your computer: CPU - Intel Core i3, 4GB, motherboard-Gigabyte H55N-USB3, keyboard and mouse - Logitech K260, monitor - DELL U2412M. If you know the source or you have information regarding this problem, please help. Do not offer me a ubuntu 11.04/11.10/12.04 LTS, I'm not going to move to another distro because of simple problems, I am sure that is possible to fix the problem. Just offer me your options, and then I will review them. Thank you!

share|improve this question

closed as too localized by jrg Dec 26 '12 at 1:48

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  fossfreedom May 31 '12 at 12:41
    
Perhaps you could also let us know if you've tried a supported version of ubuntu (11.04/11.10/12.04) and if suspend works on those versions. –  fossfreedom May 31 '12 at 12:41

2 Answers 2

You mention this started happening after you updated. You also mention that you have kernel 2.6.35-22-generic. I take this to mean that:

  1. You were running 10.10 with an older kernel.
  2. You applied updates and now have the version mentioned above.
  3. Now suspend and hibernate don't work.

If so, and the new kernel didn't have an update for any problems you were expecting, an easy solution is to install the old kernel that was working fine for you:

apt-get install linux-image-generic=2.6.35-18 <or whichever version you need>

You may also need to install the matching linux-headers and linux-headers-generic packages for your kernel to be complete.

If this works, and you never want to get prompted about kernel upgrades, you can read about "pinning" the kernel package so it doesn't get upgraded. Read about pinning here:

https://help.ubuntu.com/community/PinningHowto

http://jaqque.sbih.org/kplug/apt-pinning.html

share|improve this answer

Suspend and hibernate problems can sometimes be related to the kernel (I know mine back when I used 9.* and 10.* were). If you don't want to upgrade to a supported version of Ubuntu, you could try:

  1. Booting using an old kernel (the kernel you were using before the upgrade when suspend/resume worked) or
  2. Downloading a more recent kernel and seeing if this fixes your problem.

That said, using a newer version of Ubuntu in the long run will probably result in better support for suspend/resume.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.