Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed VMware on my Ubuntu 12.04 from a .bundle file and the installation went just fine. Now when I try to open it, it says before running, several modules must be compiled.

And when I go ahead with it it gives me another error. Here are the screen shots:

enter image description here

Also, the contents of that log file are :

2012-05-31T16:32:11.071+05:30| vthread-3| I120: Log for VMware Workstation pid=25468 version=8.0.0 build=build-471780 option=Release 2012-05-31T16:32:11.071+05:30| vthread-3| I120: The process is 64-bit. 2012-05-31T16:32:11.071+05:30| vthread-3| I120: Host codepage=UTF-8 encoding=UTF-8 2012-05-31T16:32:11.071+05:30| vthread-3| I120: Host is Linux 3.2.0-23-generic Ubuntu 12.04 LTS 2012-05-31T16:32:11.070+05:30| vthread-3| I120: Msg_Reset: 2012-05-31T16:32:11.070+05:30| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/usr/lib/vmware/settings": No such file or directory. 2012-05-31T16:32:11.070+05:30| vthread-3| I120:
---------------------------------------- 2012-05-31T16:32:11.070+05:30| vthread-3| I120: PREF Optional preferences file not found at /usr/lib/vmware/settings. Using default values. 2012-05-31T16:32:11.070+05:30| vthread-3| I120: Msg_Reset: 2012-05-31T16:32:11.070+05:30| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/config": No such file or directory. 2012-05-31T16:32:11.070+05:30| vthread-3| I120:
---------------------------------------- 2012-05-31T16:32:11.070+05:30| vthread-3| I120: PREF Optional preferences file not found at /root/.vmware/config. Using default values. 2012-05-31T16:32:11.070+05:30| vthread-3| I120: Msg_Reset: 2012-05-31T16:32:11.070+05:30| vthread-3| I120: [msg.dictionary.load.openFailed] Cannot open file "/root/.vmware/preferences": No such file or directory. 2012-05-31T16:32:11.070+05:30| vthread-3| I120:
---------------------------------------- 2012-05-31T16:32:11.070+05:30| vthread-3| I120: PREF Failed to load user preferences. 2012-05-31T16:32:11.071+05:30| vthread-3| W110: Logging to /tmp/vmware-root/modconfig-25468.log 2012-05-31T16:32:11.163+05:30| vthread-3| I120: modconf query interface initialized 2012-05-31T16:32:11.164+05:30| vthread-3| I120: modconf library initialized 2012-05-31T16:32:11.191+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.195+05:30| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release 3.2.0-23-generic 2012-05-31T16:32:11.195+05:30| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h 2012-05-31T16:32:11.195+05:30| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found. 2012-05-31T16:32:11.195+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.197+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.204+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.226+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:11.226+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.229+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.237+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.260+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:11.286+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel
3.2.0-23-generic. 2012-05-31T16:32:11.290+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.295+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.300+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.305+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.334+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.339+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.344+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.348+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.353+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.356+05:30| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.356+05:30| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h 2012-05-31T16:32:11.356+05:30| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found. 2012-05-31T16:32:11.356+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.359+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.370+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.401+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:11.436+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel
3.2.0-23-generic. 2012-05-31T16:32:11.441+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.446+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.450+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.452+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.454+05:30| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.454+05:30| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h 2012-05-31T16:32:11.454+05:30| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found. 2012-05-31T16:32:11.454+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.458+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.470+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.507+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:11.563+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel
3.2.0-23-generic. 2012-05-31T16:32:11.568+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.573+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.578+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.579+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.761+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:11.762+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:11.764+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.773+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:11.801+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:11.802+05:30| vthread-3| I120: Building module vmmon. 2012-05-31T16:32:11.802+05:30| vthread-3| I120: Extracting the sources of the vmmon module. 2012-05-31T16:32:11.815+05:30| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-23-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6 2012-05-31T16:32:14.076+05:30| vthread-3| I120: Failed to compile module vmmon! 2012-05-31T16:32:50.279+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.284+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.289+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.294+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.296+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.299+05:30| vthread-3| I120: Validating path /lib/modules/preferred/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:50.299+05:30| vthread-3| I120: Failed to find /lib/modules/preferred/build/include/linux/version.h 2012-05-31T16:32:50.299+05:30| vthread-3| I120: Failed version test: /lib/modules/preferred/build/include/linux/version.h not found. 2012-05-31T16:32:50.299+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:50.303+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:50.318+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:50.350+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:50.410+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel
3.2.0-23-generic. 2012-05-31T16:32:50.415+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.419+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.423+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.425+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.601+05:30| vthread-3| I120: Trying to find a suitable PBM set for kernel 3.2.0-23-generic. 2012-05-31T16:32:50.601+05:30| vthread-3| I120: Validating path /lib/modules/3.2.0-23-generic/build/include for kernel release
3.2.0-23-generic 2012-05-31T16:32:50.605+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:50.617+05:30| vthread-3| I120: Your GCC version: 4.6 2012-05-31T16:32:50.651+05:30| vthread-3| I120: Header path /lib/modules/3.2.0-23-generic/build/include for kernel release 3.2.0-23-generic is valid. 2012-05-31T16:32:50.651+05:30| vthread-3| I120: Building module vmmon. 2012-05-31T16:32:50.651+05:30| vthread-3| I120: Extracting the sources of the vmmon module. 2012-05-31T16:32:50.666+05:30| vthread-3| I120: Building module with command: /usr/bin/make -j -C /tmp/vmware-root/modules/vmmon-only auto-build SUPPORT_SMP=1 HEADER_DIR=/lib/modules/3.2.0-23-generic/build/include CC=/usr/bin/gcc GREP=/usr/bin/make IS_GCC_3=no VMCCVER=4.6 2012-05-31T16:32:51.492+05:30| vthread-3| I120: Failed to compile module vmmon!
share|improve this question

1 Answer 1

up vote 4 down vote accepted

The problem is that VMWare is behind the times with kernel releases. Ubuntu 12.04 (Precise) uses the 3.2 kernel. To allow the VMWare modules to successfully build on it, you need to patch (fix) the modules' source code. You can find the patch Here

Follow the instructions carefully, and you should be OK.

share|improve this answer
    
That worked. Thanks. I had 8.0.0 installed. Uninstalled it, and installed 8.0.2 and tried your method. –  Programming Noob May 31 '12 at 14:57
    
I used this link :askubuntu.com/a/138969/61977 and followed the steps there. Can you tell me what is the significance of executing apt-get install patch? –  Programming Noob May 31 '12 at 14:58
    
I really do not know for sure, but the fix will not run without it. I would have to say that it readies the system to accept the fix. –  Mitch May 31 '12 at 15:07
    
Haha ok. Thanks though :) –  Programming Noob May 31 '12 at 15:18
    
I found i needed to edit the patch script (patch-modules_3.2.0.sh) and adjust the vmreqver variable to the version of vmware I was installing (8.0.3). See here for example. as for installing patch that's just the tool the script uses to carry out (you can see it in the shell script mentioned). That's why it needs to be installed before running the script. –  yuvilio Sep 2 '12 at 0:44

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.