Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

If I set the $BIBINPUTS environment varibale in my .zshrc, it is recognized by emacs-reftex (via emacsclient), if I start emacs from my zsh commandline.

However if I start using the menubar or gmrun it doesn't knot this variable. So where is the correct place to set for the whole user environment?

If there are several alternatives, let me know. Also if it changed between differend ubuntu-versions.

Edit:

I have tried to set it in ~/.pam_environment like

BSTINPUTS=.:/home/myuser/BiBTeX/:$BSTINPUTS
BIBINPUTS=.:/home/myuser/BiBTeX/:$BIBINPUTS

but it seems to have no effect (even after rebooting) and is not listed via printenv.

I am currently using ubuntu natty + gdm + xmonad.

share|improve this question

1 Answer 1

up vote 1 down vote accepted
+50

Have you tried setting it in ~/.profile and then logging out and back in? Any variables you set in that file should get set when you log in via either X or ssh/console. If setting it in there does not work, it is a bug, and you should open a bug report about it.

share|improve this answer
    
Before I asked the question I tried it, but it didn't work (despite the fact, that they were listed via printenv). However emacsclient didn't know them. After your suggestion I tried it again (and rebooted instead of just logging out and in). –  student Jun 5 '12 at 7:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.