Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to update the BIOS on Toshiba QOSMIO-G30. The exe file that i downloaded from the manufacture web site suppose to be OS independent! Yet using Wine Loader could not execute the file. Is there any way to update the BIOS using UBUNTU?

share|improve this question
add comment

6 Answers

I would highly recommend not flashing a BIOS with an .exe using Wine. Flashing a BIOS can potentially turn your computer into a large paperweight if something goes wrong.

Some manufacturers (I know Dell does for example) have alternative BIOS upgrade methods for Linux.

However if Toshiba does not offer any Linux compatible options, your best bet is to:

  1. Determine if you really need to do the update. If you aren't having any problems with the BIOS currently and don't require any new features from it you can probably safely ignore the update.
  2. If you do require the update, either create a DOS boot disk (Mitch's answer links to a good how-to for doing this), install DOS/freeDOS etc. onto a new partition, or -gulp- install Windows. If you have an extra old hard drive around you could also install this hard drive, put windows on it, flash the BIOS and then switch back to your hard drive with Ubuntu on it.
share|improve this answer
    
Thanks for the response . there is not good reason why i should update the bios now . I thought it might help in recognizing the graphic card since Ubuntu does not! otherwise everything is functioning OK. I agree that Mitch's recommendations seem to be the best way out. –  Khaled Musleh May 31 '12 at 11:54
    
@KhaledMusleh It is very unlikely (if not impossible) that updating the BIOS will help Ubuntu recognize your graphics card. If you haven't already, open jockey (Also know as Additional Drivers) and see if you can enable a driver for your graphics card. –  adempewolff May 31 '12 at 12:00
1  
@KhaledMusleh In addition, it's probably related to this. - askubuntu.com/questions/85318/… –  jrg May 31 '12 at 12:06
    
I tried many time all the different graphic drivers supplied by ubuntu that can run 3D but none works . even in all versions of ubuntu. i found out that there is a similar card on the black list but not the same . the GT version is on the black list but not my card which have the same name-nVidia GeForce Go 7600. –  Khaled Musleh May 31 '12 at 12:35
    
@KhaledMusleh I would suggest you make a new question specifically about your graphics card with all the information about your card and what you have tried. Nvidea does not make a different linux driver for every different card, so the name would not be the same. Enabling the recommended Nvidea driver on the blacklist will likely fix your problem. –  adempewolff May 31 '12 at 12:43
show 1 more comment

This site explains how to go about doing a BIOS update under Linux.

Quoted from the same site:

So you've finally made the move to a Windows-free computer, you're enjoying your brand new Linux OS, no Trojans/viruses, no slowdown, everything is perfect. Suddenly, you need to update the BIOS on your motherboard to support some new piece of hardware, but typically the motherboard vendor is offering only DOS based BIOS flash utilities. You panic! Fortunately, this problem is easy to solve...

Below are the steps to follow:

Step 1: Download FreeDOS boot disk floppy image

Step 2: Copy your BIOS flash utility and new BIOS image to the mounted floppy disk image

Step 3: Burn a bootable CD which will emulate floppy device for use

Step 4: Reboot, flash, reboot, enjoy your new BIOS

Source: linuxinsight.com

share|improve this answer
    
after many times of tries i think your choice is probably the best way to solve the problem. however after reading the DOS based BIOS flash method i find it difficult for me to do. –  Khaled Musleh May 31 '12 at 10:11
    
Take you time reading it, and I`m sure that you can do it.:) –  Mitch May 31 '12 at 10:14
    
I will try to read carefully the steps and evaluate if it is worth the risk . than you Mitch –  Khaled Musleh May 31 '12 at 11:44
    
Unfortunately the BIOS image is larger than the 1.44Mb disc image. :-( –  artfulrobot Oct 4 '13 at 8:02
    
That's fine. because you\re creating a bootable CD, and not a floppy. –  Mitch Oct 4 '13 at 8:20
add comment

That's not going to work.

Depending on the tool provided by Toshiba, you must either:

  • run the exe file on a real Windows
  • create a DOS boot disk

If Toshiba is providing an exe file for the second option, you can try creating a FreeDOS image to run the file. I found a description for Gentoo how to do that.

share|improve this answer
    
thanks for the respond . I will try the second option because the instillation programs that come with the computer do not work! –  Khaled Musleh May 31 '12 at 9:52
    
I meant windows can not be installed even a retail version of window could not recognize the 2 HD on the laptop. the only OS that works with the laptop is UBUNTU. I am hoping that if i update the BIOS then I might be able to run 12.04 3D ! –  Khaled Musleh May 31 '12 at 10:21
add comment

Flashing using only GNU/Linux (No floppy disks, No CDs, No DOS, No FreeDOS, No Win*)

Usually there are two files:

  • a binary file which includes all the data (firmware) which is going to be transferred to the motherboard's rom chip,

  • a binary file which is an executable utility and is used to make the actual transfer of the firmware to the motherboard, plus some checks.

Manufacturers may combine these two binaries into one self extracted compressed executable file (.exe which is like a .zip file).

In this case a GNU/linux user can unzip the .exe file and extract the firmware file. Then using the flashrom utility can flash the new firmware to the motherboard.

I have tested this procedure using a Gigabyte GA-Z68MA-D2H-B3 (rev. 1.3) and an .exe file which included F10 firmware revision.

The procedure

To make a backup of the old firmware:

  • flashrom -p intenal -r backup.rom -o backuplog.txt

To make the writing of the new firmware, replace Z8MAD2H3.F10 with your new firmware:

  • flashrom -p internal -w Z8MAD2H3.F10 -o writelog.txt

To revert from an unsuccessful writing, if you completed the backup at the first step:

  • flashrom -p internal -w backup.rom -o restorelog.txt
share|improve this answer
    
And no laptops either according to the man pages –  ubfan1 Sep 28 '13 at 22:15
add comment

There is no such thing like OS-independent binary executables. As "exe file" probably means "a file whose name ends in .EXE", that's most likely either a Windows Portable Executable or an MS-DOS executable.

BIOS upgrade are really supposed to be something low-level you can do with a simple system, such as MS-DOS or FreeDOS.

So the first step here is to check whether the executable is an MS-DOS executable or a Windows executable. If it is a windows executable and it does not run under Wine, try to see if it is somehow extractable using an archiving tool (sometimes unzip may be able to help here), so you get the flash image and maybe MS-DOS flash tools (it would not be the first time MS-DOS tools are packaged inside a windows-only installer).

With no flash tools, there are generic flashers like Uniflash that are worth a try. If you want to run it and it is windows only, a good choice is probably to get a Windows Preinstallation Environment live CD, which has the basic system and will be able to run the flash tool, but unfortunately that requires a Windows license.

If you're lucky and you get a set of MS-DOS tools, just grab some FreeDOS live CD or floppy image and boot into FreeDOS to use the tools (although you will need to have the tools in a separate floppy/pen/CD). If you are even luckier, you may get a ready-to-boot disk image (as many people pack floppy images inside floppy image writers, that's possible, too).

share|improve this answer
    
Thanks for the response njsg. the file is win/DOS program. since i can not re-install windows from the discs that comes with the laptop and even a retail windows version could not recognize the 2 HD on the lapto, then the only option left is to use the DOS OS. –  Khaled Musleh May 31 '12 at 12:02
add comment

For all of those who are afraid to flash your BIOS because of people scaring you from doing it... DO IT. BIOS updates come out for two main reasons: to fix bugs, or increase performance. They aren't developing updates for the hell of it.

With that said, if you aren't experiencing issues I do encourage you to wait maybe a couple of weeks after release to install the update. This will give the package maintainer time to issue another update in the event of an unexpected issue occurs after release.

One other suggestion: most BIOS software support flashing the BIOS directly from setup by choosing the BIOS update from a storage device (like a USB drive). You should check if you can install it directly first by rebooting and pressing esc/f2/del to enter BIOS setup. Only if you can't install it directly should you resort to installing it via OS binary, as that's where issues are usually brought about anyway.

Updates come out for a reason, install them. Good luck.

share|improve this answer
    
Your answer is in my third paragraph :P sorry for the verbosity. You can probably flash directly from BIOS if you have the file on removable storage (depending how old). –  rocksfrow Oct 27 '13 at 2:49
    
Oh by the way, if installing directly via BIOS you should look for a .ROM, .CAP or maybe something else. But you wouldn't want the executable. –  rocksfrow Oct 27 '13 at 2:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.