Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a desktop with a Fritz USB WLAN N stick and tried Ubuntu 12.04. Installation went fine and WLAN is working. However, connection drops permanent. Reconnecting manually fixes it but after a few minutes it drops again. It's connected to a Vodafone 802 box with WLAN N fix set. It seems that it works when I switch off N mode. But I need to test. Can someone confirm this issue or is there another solution?

I have another machine with 12.04 (HP 625 laptop) running where connection is stable.

share|improve this question
Does you other machine have Wireless N? – Mitch May 31 '12 at 5:50
Yes every machine (laptop, dekstop pc, tablet and mobile) is Wireless N. Therefor I set my Vodafone box fix to N. Now as mentioned N is disabled completely. The weired thing is that the connection gets lost but it seems (taskbar icon sais connected) still connected, however no packets are going through. need to switch off wlan and switch on again to fix connection. – Chris May 31 '12 at 6:34
Run tailf /var/log/syslog and watch carefully what is printed when the wireless disconnects. Hopefully there are helpful error messages. Add them to your question or try googeling them yourself! – lumbric Jun 3 '12 at 10:20
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. – Jorge Castro Jun 4 '12 at 16:36

Perhaps a dupe here. The tricks below worked for me a day but now they are again not working, irritating! So this case is not resolved at least with Thinkpad X220.

I. Generic partial solution

The tip by this article here does not solve it but makes it a bit better:

$ sudo /etc/init.d/networking restart

The fix is still missing, investigating.

II. Some Intel models

Apparently a fix by Chili555 here is

$ sudo modprobe -r iwlwifi
$ sudo modprobe iwlwifi 11n_disable=1

so send feedback to Intel to fix this stupid recurring bug, this is old! The latter apparently works for Intel Ultimate-N 6300. I tested this on X220 Lenovo Thinkpad -laptop and it worked, hopefully a lasting solution -- this makes very bad reputation to Intel as non-professional provider!

Perhaps related, a ton of material in google but hard to find the relevant

  1. Some summary of things, looks similar as my found solutions or hacks, here

  2. [BUG] The recurring bug already filled by Redhat here.

  3. [RESOLVED] Dell 1390 wireless (BCM4311) Ubuntu 12.04 no wireless icon in unity

  4. [Reported? Bug?] Cannot connect to WLAN with increased frequency

  5. [Resolved, related?]

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.