Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Today I installed Ubuntu 12.04 and Ubuntu didn't detect 3G usb modem

I tried with usb_modeswitch but nothing happened. I have Alcatel one touch X200D and isn't showing Mobile Broadband option in the network manager indicator.

Here is pictures of output of lsusb and usb-devices command

lsusb:

usb-devices:

I hope you will help me.

I only have only Internet so it will be hard to make upgrade because of this problem.

share|improve this question
add comment

3 Answers

(Data, from your image)

This USB device is brand/model ID 1bbb:0000, which is not a modem. This simply means the device has auto-configured itself as USB flash storage.

Device needs to be reconfigured (using USB_modeswitch) to be 1bbb:0017 (or similar).

share|improve this answer
    
In that case, give the reconfiguration instruction. It may be a comment instead –  Anwar Shah Jul 19 '12 at 6:22
add comment

i I solved my using the software sakis3g http://www.sakis3g.org/versions/latest/i386/sakis3g.gz

share|improve this answer
1  
Can you provide more information, or at least add a link to the home page (as that is a download link, and it's not totally clear what to do with the downloaded .gz archive)? –  Eliah Kagan Sep 2 '12 at 12:14
add comment

Sakis3g is best, you can download it from

http://www.sakis3g.org/versions/latest/i386/sakis3g.gz

or the x86_64 version also.

Only compatible for GSM at present.

All you need to do it download and extract the script file sakis3g somewhere.

$ cd /path/to/sakis3g
$ sudo chmod +x sakis3g
$ sudo ./sakis3g

A GUI follows, where you will be asked for very few details. Also it prompts for username and password. If you don't have username or password, simply enter anything and hit OK.

Hope this works, if not, please let know.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.