Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I used a friend's Android (2.3) phone that allows USB tethering, subheading: "share phone's mobile network with PC."

Android lets me set 2 tethering settings, under "USB tethering type":

  • Windows
  • Mac OS X

Naturally, Linux isn't officially supported, but I suspect someone has run into this before. What do I need to on my Ubuntu 12.04 setup to get it to recognize either of these connection types for USB tethering?

share|improve this question
Can't you try both and test which works better? – desgua May 30 '12 at 21:18
You would be better off if your friend would root their phone... then it would work across the board without giving an OS option. – itnet7 May 30 '12 at 21:55
I do USB tethering all the time with my Android phone, but per the above it is rooted and using a custom ROM.. CM 7.2. Once the phone is in tether mode, Ubuntu recognizes it as a "wired" connection, no other configuration is required. – Kendor May 30 '12 at 22:29
@desgua, I tried both and neither worked! I suspect rooting may be the only solution, unless there's something on the ubuntu-end that can mimic PC or MacOS and solve this. – Mittenchops May 31 '12 at 18:45
Maybe you can get an app at Google Play to just turn on usb tethering, default? It works great at Ubuntu. – desgua May 31 '12 at 19:34
up vote 3 down vote accepted

My last phone ran Android 2.3 and i had no problems with USB tethering. I could set the USB connection to default to tethering and all i had to do was plug it in to my Linux laptop and it was online. So it's not Android 2.3 - but it may be your carrier. I believe Optus may not allow tethering on prepaid. I'm with Telstra and they do.

share|improve this answer
I think you're right---oddly, it was setting the default that worked, rather than just changing the current setting. I assume without changing the default, it was still trying to mount the drive or something? Not sure, but it works fine now. – Mittenchops Jul 24 '12 at 19:21
gsm galaxy nexus here. I only have the option to enable usb teethering, no prompt about OS type. – Fred Thomsen May 21 '13 at 4:59
@FredThomsen: That prompt only appears if no OS is set in the tethering options. – Daniel Hilgarth Jul 24 '13 at 20:20

Yes..I have also experienced same problem. This is due to carrier. I am from India. There are two carriers namely IDEA and AirTel. I was able to connect with IDEA on 3G but for AIRTEL no luck but when I switched Airtel network to 2G, I was able to connect sadly speed was low. May be you can change the network type

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.