Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I m having lot of problems in my newly install ( also in fresh installed copy ) of ubuntu 11.10

whenever i try to download any software the download stuck at certain point always e.g. teamviewer 14.4 mb, google chrome 26.7 mb.

if i tried sudo apt-get- upgrade it will stuck at [waiting for headers]

same happens with sudo apt-get install mysql-server install & download...

i can't determine the problem.

i tried switching server from India to main server still the problem continues.....

can someone please solve this problem

share|improve this question
    
Have you checked you Internet connection? –  Mitch May 30 '12 at 17:25
    
can you post your lspci –  Mitch May 31 '12 at 5:06
add comment

2 Answers 2

up vote 0 down vote accepted

I was getting the same problem in 11.04. Upgrading to 12.04 corrected the problem. Try installing the updates.

share|improve this answer
add comment

To speed up downloading of updates you can do the following:

Go to Ubuntu Software Center > Edit > Software Sources or (update Manager > settings) and from Download from drop down menu choose Other then on the next window choose Select Best Server and wait for it to pick the best server for you, then run sudo apt-get update again.

share|improve this answer
    
my connection speed is 1mbps works fine for me never drops and my select best server process stuck too :( before everything was working fine i m having problem since 2 days only :( download always stuck certain points in some softwares only :( –  Ankit Pise May 30 '12 at 17:48
    
i m totally unable to download packages in mb even in updates :( –  Ankit Pise May 30 '12 at 21:05
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.