Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to print, for some reason all the printers I previously had installed have disappeared.

I pulled up the "Printing" dialog, and I see that localhost is "Not connected," but when I try to connect, it fails. I have looked this up in various places, but the only two suggestions I've found have not worked. The first was to put apparmor into a less strict mode, and the second was to reset CUPS. I've done both of those things, and to no avail.

I just want to print again!

share|improve this question

closed as too localized by Luis Alvarado Mar 14 '13 at 16:33

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

How are the printers connected? Via network, or via usb? – txwikinger Aug 6 '10 at 18:34
They're networked, but it seems like CUPS just isn't working, so I'm not sure it would matter. – mlissner Aug 6 '10 at 18:40

What do you think where 'localhost' aka goes? Thats your network-card and if there is a printer connected it will have annother ip-address. So printing on will not work. Try install a new printer in your printing dialog, if it will be identified thats ok, if not post some more information about your network.

share|improve this answer
The printer was installed properly before, but at this point, I can't even add new printers, because it seems like CUPS must not be running (when I try, the option is grayed out). I haven't changed anything about my network or CUPS to my knowledge? – mlissner Aug 6 '10 at 22:15

How funny! I just was looking for a permanent solution to this problem.

Here is what will fix it when it happens.

Open Terminal: type: sudo /etc/init.d/cups restart hit enter enter your password and the problem should be solved.

My issue is that it is not a permanent fix. I have to keep repeating it anytime my computer is restarted. This seems to be a new issue with 10.04.

I would love to hear a permanent solution.

share|improve this answer
Yeah, as I mentioned above, that doesn't do anything for me - temporary or permanent. – mlissner Aug 6 '10 at 18:57
@Tom You can, If you want make a script that will run on boot. That would be a sorta permanent solution. – Micheal Harker Aug 6 '10 at 19:08


check this is the path to your cups server.


Click ubuntu logo and then search printing. Hover near the top to get server and click this then click edit and check the path above is entered

before unity:

printing preferences ( think it's system on the menu at the top ) basically the window with all your printers in. Click server and edit and then check the path at the top is entered.

Don't forget to logout and log back in if you've changed the path.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.