Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am completely new to Ubuntu. I experimented with Ubuntu 12.04 by running it from a USB drive, in-order to recover files from my hard disc.

History: My laptop is an IBM R60 running windows 7. Suddenly it gave me an error stating "error 2100 - Hard drive initialization error".

I have read all the forums and most of them suggested that I remove and replace my HDD and that did not work. And one site suggested to try using Ubuntu to recover files.

I booted my system from USB, and once Ubuntu came up, I choose "Try Ubuntu". It came up fine and I was able to surf ,and do other things, etc. I was unable to to access my files which are on the hard disc and "Attached Devices" is grayed out.

1- Is there any way to gain access to my hard disc to recover the files? How do I navigate to search for my files.

2- Is it just simply not possible if the hard disc themselves are not working? Is that why I`m unable to find the drives.

I know its a very novice question, but hoping someone would help me out.

Thank you,

Eapen

share|improve this question
    
When Ubuntu came up, and you clicked on the Home Folder, what was listed ubder devices? –  Mitch May 30 '12 at 15:55
    
If your hard disk is damaged then forgot that ubuntu or other linux based OS will recover your files. You should better go to a technician to recover your files! –  Ravi May 30 '12 at 16:04
    
@eapen One thought would be to start the disk utility to see if it can see the drive. There is a mount drive command in the application so if it can see it, you can force it to mount. My guess, by the error you reported, is that nothing will be able to read the drive though. –  Mordoc May 30 '12 at 16:33
    
@all yeah i tried everything possible but the drives are not being detected, guess il have to just try removing my hdd and use a casing as an external hdd to see if it works. but thanks soo much all of you. tough luck i guess. –  eapen jacob May 31 '12 at 4:59
add comment

2 Answers

It could be that the hard disk controller on the motherboard is broken. If so that would explain why it did not work even if you installed a new HDD...

share|improve this answer
add comment

Same issue here. I located the problem in the BIOS. The reason the hard drive doesn't get detected is because the BIOS just doesn't understand how to boot from a usb stick (some driver missing i'm guessing) My motherboard is XFX MI-A78S-8209.

1)If you select boot priority from the flash drive, but USB flash as second hard disk windows will start up without even talking to the flash drive first.

2)If you set the flash drive as first hard disk in the BIOS then it wont recognize the hard drive. I used Yumi and universal boot loader to make the different USB flash drives but all combinations fail. Yumi definetely changed some of the bios options where it gave me the option to boot from three devices but still no detection of the hard drive. Having eliminate the credibility of the iso file, flash drive stability (two different flash drives ((1GB) and (4GB HP) it really doesn't leave much options besides updating the BIOS from XFX site. CPUZ will allow you to find out what your motherboard info is(free). Also Gpart from ubuntu wont recognize the hard drive either, I figured maybe a partition would help. Another option might be delete MBR records but thats just being silly :).

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.