Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a Thinkpad W520 with Nvidia Optimus graphics. I have disabled the Nvidia card in BIOS (by selecting "integrated graphics"), so I'm running only on the integrated Intel graphics. I get full 3D acceleration, which would suggest the drivers are properly installed. However, I'm not able to use an external monitor. With the external monitor connected and turned on, running xrandr always gives:

$ xrandr
Screen 0: minimum 320 x 200, current 1920 x 1080, maximum 8192 x 8192
LVDS1 connected 1920x1080+0+0 (normal left inverted right x axis y axis) 344mm x 193mm
   1920x1080      60.0*+   59.9     50.0  
   1680x1050      60.0     59.9  
   1600x1024      60.2  
   1400x1050      60.0  
   1280x1024      60.0  
   1440x900       59.9  
   1280x960       60.0  
   1360x768       59.8     60.0  
   1152x864       60.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)

What gives? It sees the VGA1 port (to which the external display is connected), but it appears disconnected.

I have tried forcing a resolution as per these instructions, but when I do that X becomes unresponsive and I have to Ctrl-Alt-F1 and restart it.

share|improve this question

Welcome to the joy of owning a laptop with Optimus. As a fellow sufferer, here's what I've had to do:

These instructions from Sagar Karandikar work on 12.04 and 12.10.

The trick is, that if you're running 12.10, you need to download a version of the intel display patch that is equivalent to the closest driver you can manage from here. I managed to find a driver matching versions for Raring.

Then, set up a script to run the display commands, change the flag from VIRTUAL to VIRTUAL1, and you're set.

share|improve this answer

If you care about having the option to switch between the nVidia and intel chips, try Brian's solution. If you're fine just using the nVidia chip, select the 'discrete graphics' option in your BIOS. I've read somewhere that the VGA port is not wired to the intel chip so you'll have to enable the nVidia chip to use the extra port. I had a problem similar to yours and this seemed to fix my issue.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.