Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I want to install openssh-server, so i do this:

erik@workstationubuntu:~$ sudo apt-get install openssh-server
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 dassault-systemes-draftsight:i386 : PreDepends: libdirectfb-extra:i386 (>= 1.2.7-2) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

erik@workstationubuntu:~$ sudo apt-get -f install
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Correcting dependencies... Done
The following packages will be REMOVED:
  dassault-systemes-draftsight:i386
0 upgraded, 0 newly installed, 1 to remove and 1 not upgraded.
After this operation, 297 MB disk space will be freed.
Do you want to continue [Y/n]? n

erik@workstationubuntu:~$ sudo apt-get install libdirectfb-extra:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 libdirectfb-extra:i386 : Depends: libdirectfb-1.2-9:i386 (= 1.2.10.0-4.3ubuntu1) but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
erik@workstationubuntu:~$ 

erik@workstationubuntu:~$ sudo apt-get install libdirectfb-1.2-9:i386
Reading package lists... Done
Building dependency tree       
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
 dassault-systemes-draftsight:i386 : PreDepends: libdirectfb-extra:i386 (>= 1.2.7-2) but it is not going to be installed
 libdirectfb-1.2-9 : Conflicts: libdirectfb-1.2-9:i386 but 1.2.10.0-4.3ubuntu1 is to be installed
 libdirectfb-1.2-9:i386 : Depends: libsysfs2:i386 but it is not going to be installed
                          Depends: libts-0.0-0:i386 (>= 1.0) but it is not going to be installed
                          Conflicts: libdirectfb-1.2-9 but 1.2.10.0-4.3ubuntu1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
erik@workstationubuntu:~$ 

And this goes on!

Can i some install openssh-server without removing draftsight? (note that i had to use dpkg --force-depends when installing draftsight (it works flawless)

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The reason why your dependencies are broken is because you have forced install draftsight package which was meant for the i386 architecture. Clearly, you are using the amd64 architecture and hence the broken dependencies is preventing you from installing any further packages.

One possible solution would be to remove draftsight package for the time being and then install openssh-server and then install it back again. Note that you have to do this every time you are updating and upgrading your system.

Or perhaps, if you can find a package meant for amd64 architecture, you can install that and I reckon your dependencies won't be broken anymore.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.