Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently installed a second hard drive on a Windows XP computer. I installed Ubuntu 12.04 from DVD-ROM onto the second drive, using the installer to partition. When I start the computer, I do not get the option to choose the operating system, and Windows shows the drive (F:) as not having any Linux files. What is my next step?

share|improve this question
    
Have you tried reinstalling GRUB 2? –  Mitch May 30 '12 at 6:22
    
you did general install of Ubuntu or WUBI based ? If general install make the 2nd drive which have Ubuntu as a primary booting drive from BIOS settings . –  Raja May 30 '12 at 6:24
    
Where did you install Grub when asked? Which drive boots first in BIOS? –  Takkat May 30 '12 at 6:30
    
David, what actually loads when you start the computer? If Windows, you may just need to boot from the second hdd. That should give options to boot both Ubuntu and Windows. –  mikewhatever May 30 '12 at 7:35

1 Answer 1

This may answer your question; however, there could be a variety of problems with this, but I hope I'll find the solution for you.

First, whenever you boot, hold down both Shift keys as soon as your computer hits the BIOS screen. Normally the Left one is necessary, but both won't hurt. :) What this does is, if it is configured already, will display the GRUB selection menu. GRUB, or the GRand Universal Bootloader, will list both Ubuntu and Windows booting options. If this doesn't work, read on.

The problem may be that the partition with GRUB on is not being booted, but the Windows one is. Boot from your Ubuntu DVD/CD/USB and select "Try Without Installing". Now, open up terminal from the Unity dash. Run the following commands:

sudo add-apt-repository ppa:danielrichter2007/grub-customizer

sudo apt-get update

sudo apt-get install grub-customizer

Then, with the Dash, open up Grub Customizer. Now, click on Preferences on the top right corner. Now, look for default entry and select the Ubuntu partition (Not recovery). Click close, Save, and close the application. Now, reboot. It should now load GRUB.

Edit: This solution is for if you have Ubuntu installed on a separate partition; it may work for separate hard drives, however. I do not know from experience if this works for multiple drives, but I know that it works for separate partitions on ONE drive.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.