Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I connect my 3G USB Modem to my laptop with 12.04, nothing shows up in Network-Manager. This modem is working in 11.10 and the modem is shown in Network-Manager but not in 12.04 !!

Here are the outputs of lsusb and usb-devices on two machines , one with 11.10 and the other with 12.04 :

Ubuntu-11.10 :

$ lsusb
    Bus 002 Device 009: ID 1c9e:6061  

$ usb-devices
    T:  Bus=02 Lev=02 Prnt=02 Port=03 Cnt=01 Dev#=  9 Spd=12  MxCh= 0
    D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=6061 Rev=00.00
    S:  Manufacturer=3G USB Modem        ￴￴
    S:  SerialNumber=000000000002
    C:  #Ifs= 4 Cfg#= 1 Atr=a0 MxPwr=500mA
    I:  If#= 0 Alt= 0 #EPs= 3 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 1 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 2 Alt= 0 #EPs= 2 Cls=ff(vend.) Sub=ff Prot=ff Driver=option
    I:  If#= 3 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=usb-storage

Ubuntu-12.04 :

$ lsusb
    Bus 002 Device 003: ID 1c9e:6061 OMEGA TECHNOLOGY WL-72B 3.5G MODEM

$ usb-devices
    T:  Bus=02 Lev=01 Prnt=01 Port=01 Cnt=01 Dev#=  3 Spd=12  MxCh= 0
    D:  Ver= 1.10 Cls=00(>ifc ) Sub=00 Prot=00 MxPS=64 #Cfgs=  1
    P:  Vendor=1c9e ProdID=6061 Rev=00.00
    S:  Manufacturer=Qualcomm, Incorporated
    S:  Product=USB MMC Storage
    S:  SerialNumber=000000000002
    C:  #Ifs= 1 Cfg#= 1 Atr=c0 MxPwr=100mA
    I:  If#= 0 Alt= 0 #EPs= 2 Cls=08(stor.) Sub=06 Prot=50 Driver=(none)

As the output of the above commands show, the device is detected as a modem in 11.10 but in 12.04 it is detected as a USB storage (the device is both a 3G Modem and a SD-card USB adapter).

Any help ?!

share|improve this question
    
What's the module and how is it connected? –  Cry Havok Oct 20 '10 at 9:54
    
and what exactly is the problem? you'll need to provide a lot more information if you expect anybody to understand your problem. –  Stefano Palazzo Oct 20 '10 at 9:56
5  
Is the stick recognized if you try to create a new connection under System -> Preferences -> Network Connections -> Mobile Boradband? –  Bobby Oct 20 '10 at 10:01
    
I always put the mobile broadband into USB port and wait for anything happen. but nothing happens. I am newbie. I apologize if you are not really understand of my question –  ok comp Oct 20 '10 at 10:36
1  
@ok comp what is the make and model of your 3G device? What ISP/Telecom provider are you with? –  Nick HS Oct 24 '10 at 11:13

11 Answers 11

I have Huawei E156 HSDPA (3G) USB Stick and I did the following, also it worked for my samsung 3g mobile via usb cable.

sudo apt-get install wvdial

after installing wvdial type following lines in terminal to edit wvdial.conf

sudo gedit /etc/wvdial.conf

Paste into your editor, the following lines:

[Dialer name]
Modem Type = Analog Modem
Phone = *99#
ISDN = 0
Baud = 460800
Username = " "
Password = " "
Modem = /dev/ttyUSB0
Init1 = ATZ
Init2 = at+cgdcont=1,"ip","your Access Point Name"
Stupid Mode = 1

Whenever you have to connect just type in your terminal

sudo wvdial name

Now you will be online with blazing speeds. I think this method is less time consuming and fast than another method.

share|improve this answer

I have an idea as net setter is working in ubuntu 10.04, 11.04 etc.
Connect & add a mob bb connection in network manager. For help with Network Manager look here

share|improve this answer
up vote 16 down vote accepted
+100

After a lot of searching and reading in different forums I found a solution to my problem. Please note that while the other answers didn't solve my problem, they might be helpful to others facing problems with 3G USB Modems (specially the sakis-3g script).

I found my solution in this thread, which I will detail in the following:

When connecting my USB modem, it is detected as a USB storage. According to that thread, running sudo modprobe option could make the device be detected as a modem. If not, it is also suggested to execute the following commands:

sudo su
echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id

where 1c9e 6061 is the device ID obtained from the lsusb command. This worked for my device and it was detected in Network-Manager. Note that you must become root using sudo su and running the command with sudo won't work.

To automate things, the following steps are presented:

  1. sudo su
  2. nano /usr/bin/usbModemScript and put the following in the file:

       #!/bin/bash
       echo 1c9e 6061 > /sys/bus/usb-serial/drivers/option1/new_id
    

    Then save the file (Ctrl+O) and exit nano (Ctrl+X).

  3. chmod +x /usr/bin/usbModemScript

  4. nano /etc/udev/rules.d/option.rules and put the following in the file:

        ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/usr/bin/usbModemScript"
        ATTRS{idVendor}=="1c9e", ATTRS{idProduct}=="6061", RUN+="/sbin/modprobe option"
    

    Then save the file (Ctrl+O) and exit nano (Ctrl+X).

  5. reboot

NOTE : You should replace the values 1c9e and 6061 with the appropriate device ID values of your own modem.

After reboot, your modem should be detected when connecting it to the computer. Of course, this might not be the case (as it wasn't for me)! My device wasn't detected correctly after the first time it was connected to the computer. Instead, I had to disconnect and then reconnect it, and this time it was correctly detected as a modem in the Network-Manger. Some people might also need to restart the network-manager service (as I did):

sudo service network-manager restart

================================================================================

Another potential solution is to use wvdial.

  1. Installation: sudo apt-get install wvdial
  2. Connect your modem to the computer.
  3. Run: sudo wvdialconf /etc/wvdial.conf. If it says 'no modem found' then you are out of luck!
  4. If the modem is found, run: sudo nano /etc/wvdial.conf and input your ISP information where needed by filling the fields you know about. Run man wvdial.conf in a separate terminal for information about the options. Once you are ready, save the file (Ctrl+O) and exit nano (Ctrl+X).
  5. Now try to connect: sudo wvdial

For more information on wvdial, read the man page (i.e. man wvdial).

Hope this helps :)

share|improve this answer

have you tried to use usb_modeswitch:

http://wiki.ubuntuusers.de/USB_ModeSwitch

to change the type from USB MMC Storage to 3G USB Modem?

share|improve this answer
    
I assumed that UsbModeSwitch is a pre-installed module on modern Linux dirtros! Anyway I found another way to switch the device type, which I will fully explain as an answer. –  Seyed Mohammad Jun 6 '12 at 6:05

Just, use alternative connection, full update ubuntu. Connect again using your 3g Dongel.

And it will work fine!

share|improve this answer
    
I always keep my Ubuntu installation up-to-date (every-day), but unfortunately that didn't make my modem show-up in Network-Manager. –  Seyed Mohammad Jun 6 '12 at 5:55
    
But it worked for me, try to use Wv Dial –  BigSack Jun 6 '12 at 10:53

For this USB MODEM, try sakis-3g. You can download it: http://www.sakis3g.org/#downloading

share|improve this answer
    
No I haven't tried that script. I was hoping there would be a standard solution to the problem, specially since the device works fine with the previous version of Ubuntu (i.e. 11.10). –  Seyed Mohammad Jun 6 '12 at 5:57

try

sudo modprobe usbserial vendor=0x1c9e product=0x6061

And wait for some time. It always works for me

share|improve this answer
    
What should happen after this command ? Should it show-up in Network-Manager ? –  Seyed Mohammad May 30 '12 at 5:32
    
yep, I hope so. –  virpara May 30 '12 at 5:43
    
modprobe - program to add and remove modules from the Linux Kernel –  virpara May 30 '12 at 5:47
    
Unfortunately this command didn't solve the problem and still there is no Mobile Broadband connection in my Network-Manager. Thanks for helping anyway. –  Seyed Mohammad May 30 '12 at 6:04

I have a huawei-ec1261 modem and I made it work following this

http://open-help.blogspot.com/2010/10/how-to-setup-tata-photon-plus-on-ubuntu.html

Hopes it helps u too

share|improve this answer
    
New location: theopenhelp.com/2010/10/… –  Guandalino Jun 12 '11 at 15:02

install usb-modeswitch and use wvdial or gnome-ppp to connect to internet. You will also be able to connect using network manager if your modem is detected. usb-modeswitch is the trick.

If your modem has custom drivers available then install them.

share|improve this answer

Do you know what brand and model your modem is? Huawei, Option or Sony Ericsson? Some Huawei models need some tweaking. At the danish site here: http://scripts.linux.dk/joomla/index.php/mobilt-bredb%C3%A5nd/mobiltbredbans.html you can download and run a script that will make most Huawei models work. You can translate the page with google translate ;-)

share|improve this answer
    
I used Huawei once, for the usb-modeswitch, it srill cannot work, because nothing still happen, even my mobile broadband modem didn't being detected. just the lights of my broadband keep blinking –  ok comp Oct 26 '10 at 5:21
    
I also already download scripts.linux.dk/joomla/index.php/mobilt-bredb%C3%A5nd/… the following link, but the result still the same –  ok comp Oct 26 '10 at 5:22
    
now I am using CSL U2-TF modem, made in China that I borrowed from my brother. an the results is still the same. my ubuntu doesnt detect it –  ok comp Nov 27 '10 at 17:47

Did you install usb-modeswitch ? Ubuntu 10.10 must have come along with it . Try to check with Synaptics whether usb-modeswitch is installed . Once installed , plug in your USB modem and wait . There will be an option at the connectivity icon where it writes create new mobile broadband . Then follow the steps from the window . Im using usb modem with Ubuntu 10.10 and it runs fine . =)

share|improve this answer
    
its already installed. but once I plug the modem in, still nothing happens. FYI, I'm having this problem since I'm using Lucid –  ok comp Oct 24 '10 at 13:22
    
what is the model of your USB modem ? –  Wilsonzaizai Oct 25 '10 at 7:52

protected by Community Nov 3 '12 at 22:11

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.