Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am running Ubuntu Server 12.04. I have a wireless USB card. When I begin the boot process I see:

Waiting for network configuration

It turns out that the network never comes up. But once I get to the command line, if I type: ifup wlan0, then I have network access. My /etc/network/interfaces looks like this:

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
auto wlan0
iface wlan0 inet dhcp
wpa-ssid xxxxxxx
wpa-psk xxxxxxxx

Looking in my network-interface-wlan0.log shows:

Failed to connect to wpa_supplicant - wpa_ctrl_open: Read-only file system
Failed to bring up wlan0.
Failed to connect to wpa_supplicant - wpa_ctrl_open: Read-only file system
ifdown: interface wlan0 not configured

I've looked at other askubuntu.com questions similar to this, but they don't seem to apply.

How can I get my system to network wirelessly at boot?

Additional information:

I did some poking around. Basically once I login I need to do a:

ifdown wlan0

because I think that ip thinks that is is up, but in /var/run/network the only thing that is 'up' is ifup.lo. Then I do a

'ifup -a'

and then everything works.

share|improve this question
add comment

4 Answers

up vote 7 down vote accepted

Failed to connect to wpa_supplicant - wpa_ctrl_open: Read-only file system

According to your log you 'll need to use wpa_supplicant.

So add something similar to this:

auto wlan0
iface wlan0 inet dhcp
wpa-conf /etc/wpa_supplicant.conf

Contents of /etc/wpa_supplicant.conf :

network={
        ssid="ADD-YOUR-SSID-HERE"
        proto=RSN
        key_mgmt=WPA-PSK
        pairwise=CCMP TKIP
        group=CCMP TKIP
        psk="ADD-YOUR-WPA-PASSWORD-HERE"
}
share|improve this answer
    
Perfect. Thanks pl1nk. –  Avery Chan May 31 '12 at 0:50
add comment

I also encounter such a problem.

I noticed that someone said, delete the text about primary network interface, with first 2 lines remaining.

It works, but no network is connected.

Then I write the text of primary network interface back into the interfaces file and reboot.

It's surprising to find not only no hints "waiting for network configuration" occur, but I could connect to the internet.

I don't know whether it is useful for any others.

share|improve this answer
add comment

The reason for this is that the filesystem is read-only at boot. At this point only static settings work because udev raises network hotplug signal before the filesystem is ready.

The solution is to change the /etc/init/network-interface.conf file in this line:

"ifup --allow auto ..." to
"ifup --allow=hotplug ...".

You will have to mark you hotplug PCMCI and USB network adapters as "hotplug" in /etc/network/interfaces for them to continue to work, and you should plug them in after boot, not before.

share|improve this answer
add comment

You can add ifup wlan0 to your /etc/rc.local file. Add the command ifup wlan0 before the exit 0. Also add the command ifdown wlan0 before the ifup wlan0 like so:

...
ifdown wlan0
ifup wlan0

exit 0

For some reason when Ubuntu starts, it thinks that wlan0 is up. So you have to shut it down and have it back up again.

share|improve this answer
    
This didn't work. I don't think this is happening because ifup isn't be called. I think there's something else wonky going on with the networking system. –  Avery Chan May 30 '12 at 5:52
    
Hi, ifup wlan0 should be above the 'exit 0' line. Thanks @Piyush Kumar for mentioning –  Manula Waidyanatha May 30 '12 at 6:57
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.