Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My machine one day started inconsistently to fail to boot. I found that Grub was (sometimes) unable to load either the kernel or the ramdisk (it said "out of Disk"). It got to the point where I could only boot with the Grub command line and attempt to load them manually - after serveral failed attempts, it eventually succeeded.

In my kernel logs, I found numerous "ATA bus error"s, and noticed that the disk was operating at ATA 33 instead of ATA 133. I did a full check of the disk (using the vendors bootable tool) and it came up clean (despite very large numbers of 'seek errors' - seems those are normal for my disk!).

I wasted a heap of time looking for Grub bugs and worrying about hardware failures when eventually I noticed a suggestion to check the cables....

share|improve this question

1 Answer 1

up vote 1 down vote accepted

In the end, it seems it was cables.

Following the suggestion in a bug report, I changed the SATA cable, used a different SATA power plug from my power supply (insufficient power is a possible culprit), and made sure the SATA cable wasn't near any other power cables (possible electical interference from other, especially power, cables).

It works fine now.

I've since put the original SATA cable back in, and it still works. I'll switch power cables soon, and try dangling the SATA cable near other power cables... Likely the SATA cable was either dislodged or a bad connection developed due to humidity or some such.

share|improve this answer
    
Please accept your own answer in that case so that the question is closed and it remains a useful reference for future readers :) –  izx May 30 '12 at 10:16

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.