Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a shiny new HP Pavilion g series laptop (g7). The very first boot of the system was a gparted-live usb to split out some space for Ubuntu. The second was a 12.04 live usb.

Mostly it is working extremely well. The exception is WiFi connectivity. It seems to connect at first, but then after anywhere from 30 minutes to four hours I lose connection and cannot reconnect until I reboot the router. Sometimes an RFKill block and unblock will fix it. And yesterday I saw a suggestion to remove the NetworkManager.conf file. The latter seems to have extended the time to failure to hours rather than minutes.

What should my next steps be?

Thanks

share|improve this question
    
Welcome to Ask Ubuntu! We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro May 30 '12 at 4:18
add comment

3 Answers 3

Solution found.

very simple actually. I needed to load the chipset specific driver.

I found the specific version of my chipset with lpci

Then I looked on the chipset manufacturers web site and found linux drivers.

I downloaded and extracted the tarball.

I ran "sudo make install" from terminal in the appropriate directory.

Reboot and all seems perfect.

I will try to add truly specific instructions later when I am back with my laptop.

share|improve this answer
    
those specific instructions would be quite helpful right now. –  topher Feb 8 '13 at 18:36
    
Oops, I guess I forgot to do that. (at work with windows now, can't check it.) –  Skip Huffman Feb 8 '13 at 18:39
1  
I followed these instructions. However, I got errors when running compiling the driver. I followed the instructions from linuxforums.org/forum/wireless-internet/… and applied the patch from linuxquestions.org/questions/slackware-14/…. After applying these sudo make install plus a reboot fixed the problem. –  topher Feb 10 '13 at 11:50
add comment

From what I understand it could be a driver or hardware issue if connectivity isn't the problem. If you can find out what the exact chip-set is, run a Google search and see if others have had similar problems. Other reasons things could be that configuration is all messed up, Ubuntu just doesn't support the card, or somebody's hardware is failing.

If its just this one computer having the issue and not others, then it's probably not the router. Maybe try getting one of those cheap USB WiFi adaptors. Disable the built in WiFi and use the external one. You can at least isolate the problem to the chipset.

Be sure to check the "Restricted Drivers" in the System Settings to see if there is a proprietary one to use.

share|improve this answer
    
Honestly I don't think signal strength is the issue. Where I am most of the time the router is twenty feet away with nothing but a gypsum board wall in between. Also I see three 'rings' of strength pretty much all the time. And my wife's netbook has no trouble. (Ubuntu 12.04, HP Mini) –  Skip Huffman Jun 2 '12 at 20:32
    
okay I agree with you then. Connectivity is not the issue. Lets see. Do you have this problem on other operating systems; either windows or other Linux distros? –  Prof 64 Jun 4 '12 at 0:09
add comment
up vote 0 down vote accepted

Ok, more specific Steps:

Run lspci and look for your wifi adapter

In my case it turns out to be a Realtek RTL8188CE

Googleing that brings me to the manufacturer's page. Then search for "linux" in the page's search box leads me to a big list of downloads. Here: http://www.realtek.com.tw/search/default.aspx?keyword=linux

And on that page I see my model number and click on it, bringing me here: http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNid=48&PFid=48&Level=5&Conn=4&DownTypeID=3&GetDown=false&Downloads=true#RTL8188CE

Oh look! Nice shiny driver update! Only a bit over a week old. Nice. Time to download that.

Extract tar-ixvf linux_max8*tar.bz2

cd into the directory and look at the readme file. Install is pretty straightforward. Change to superuser. Make. Make install. Reboot.

Give that a try. (Saving now. will edit after reboot.)

That worked just fine. I am going to assume that all is well and accept this answer. Hope it helps anyone watching.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.