Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

edit: Another thing that compounded/compounds the problem is that pysdm lets you add spaces in drive mount points, which I am pretty sure are not supported.

edit: So. I downloaded a program that is supposed to auto-configure NTFS programs, and it seems to have automatically put in those UUIDs for me! The problem is that I now seem to have two entries for each drive, and it's rather cluttered. (See below)

sorry to be another one of those annoying people posting fstabs left and right and saying, "Help me!" But I'm really stumped.

So I was using pysdm (the GUI frontend is "Storage Device manager") and I realised something awful. It works fine to set new partition entries, but it won't change existing entries, only add new ones. That means that if I want to change the mounted name of sda6 from A to B it makes an entirely new entry!!!

So anyways, I went and cleaned out my fstab, with one entry for each partition and the proper options (the NTFS stuff, file permissions). It still asks me what to do (skip, retry, panic, manual, whatever) once during startup - apparently it's looking for another partition that's already mounted or doesn't exist.

Could the problem be something to do with my mtab? I have no clue; I only got into Linux like 6 months ago.

What my hard drive looks like

My fstab:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
#
#
# / was on /dev/sda8 during installation
# swap was on /dev/sda6 during installation
# <file system>                             <mount point>   <type>  <options>                  <dump>  <pass>
UUID=efc87ac0-daac-4a32-9a85-ea57beff0e28  /                  ext4  defaults                        0  1 
proc                                       /proc              proc  nodev,noexec,nosuid             0  0 
/dev/sda6                                  /media/Swap        swap  sw                              0  0
/dev/sda1                                  /media/Windows 7   ntfs  nls=iso8859-1,users,noauto      0  0 
/dev/sda2                                  /media/Boot        ext2  users,noauto                    0  0 
/dev/sda3                                  /media/Acer        ntfs  nls=iso8859-1,users,noauto      0  0 
/dev/sda5                                  /media/Windows #2  ntfs  nls=iso8859-1,users,noauto      0  0 
/dev/sda7                                  /media/Fedora      ext4  users,noauto                    0  0 
/dev/sda9                                  /media/Storage     ext4  users                           0  0 

Regarding the new config:

I now, unfortunately, get this:

strange naulitus panel

Also, whenever I try to mount a NTFS partition not as root, I get this:

NTFS permissions

My new fstab, for whatever reason, doesn't seem to want to stay in blockquote without becoming headers and such, so it put it here.

share|improve this question
    
It would be better to put your fstab contents in a quote block of the question directly instead of linking to another site holding it. Also you should not be referring directly to /dev/sdXY, but should be using UUIDs instead. –  psusi May 29 '12 at 22:57
    
Sorry about that, but UUIDs are hard to manually edit and I also do a lot of drive changes. I added the blockquotes but will stick with using "sdaX" for the time being until my configuration is more...stable. Thank you for the suggestion. –  WindowsEscapist May 31 '12 at 14:23
    
An unstable configuration is the whole reason for using UUIDs in the first place. On any given boot, the order drives are detected in may change, even if you don't add or remove any, resulting in sdXX being renumbered, and invalidating your fstab. –  psusi May 31 '12 at 14:37
    
By unstable, I mean that I sometimes change partition contents, not just order. –  WindowsEscapist May 31 '12 at 14:43
    
@psusi: Have you ever actually had the order change without any external changes? I've personally never seen that happen. I agree UUIDs are best, but the old way worked adequately for a long time, and it's probably best for him to concentrate on one problem at a time, then change to UUIDs when he gets a stable system. –  Marty Fried May 31 '12 at 16:32

3 Answers 3

up vote 2 down vote accepted

The best way I know to troubleshoot problems with fstab is to use sudo mount -a from a terminal to see where the problems are, and interactively make changes until the errors are fixed.

mount -a simply mounts everything in your fstab. If certain entries mount without error, but give access problems, you might want to unmount, make edits to fstab, then run mount -a.

Using UUIDs makes the file easier to maintain, but don't get too distracted by all the people talking like it's an immediate requirement. For right now, it may be simpler to use the devices if you're willing to maintain the file whenever you make changes. Even though UUIDs make it easier to maintain, it's not an immediate requirement to fix problems, in my opinion. One problem at a time!

More on UUIDs

Once you get everything working, here's how to switch to UUIDs, and maintain them in the future.

The original fstab has a comment at the top, but here are some more details and tips: in the terminal, enter the command sudo blkid -c /dev/null. I add this as a comment at the top of fstab so it's easy to remember. The '-c' switch just makes it reread the information instead of using a cached copy, to make sure it's up-to-date. Unless you have a lot of partitions, it won't make any difference in time.

The result of this command is a list of all partitions, by device, with label, UUID, and type of filesystem. You can cut and paste the UUID into your fstab file, replacing the /dev/sdx notation with UUID=xxxxxxxx-xxx-xxx-xxx-xxxxxxxx /mountpoint ... Once you get used to it, it really isn't much trouble to maintain the UUIDs. I'd suggest leaving a comment above the line with the old notation, although remember to update it if it changes.

share|improve this answer
    
OK. Thank you! I'll try when I get the time. (Labor-intensive; I want to make sure I get everything right) –  WindowsEscapist May 31 '12 at 0:05
    
I have 2 drives with lots of partitions I use, some shared with Windows, some containing other distros I play around with, so I've had a bit of experience with fstab, mounting, and gparted. If you have problems, I'll try to help. –  Marty Fried May 31 '12 at 4:13
    
Fixed it! Thank you very much. The problem was that as well as piling multiple entries for drives, my GUI let me add spaces without warning me that it would kill it entirely. I narrowed it down two of them, re-did it, and everything's fine now! (I think) I can sudo mount -a without any bad lines showing up. Next step is to try from normal, non-root GUI (Nautilus). –  WindowsEscapist May 31 '12 at 13:58
    
Crap. Well, now I can't mount ntfs filesystems unless I'm root. (i.imgur.com/weZvj.png) ...What do I do now? –  WindowsEscapist May 31 '12 at 14:17
    
You will need to be root to mount partitions unless you have special settings in your fstab file. I don't know what the ntfs settings are for this, so I just use sudo mount if I need to - but I have my ntfs partitions mounted in my fstab anyway. The main issue there for me is to get the permissions correct for accessing it once it's mounted. BTW, how are you trying to mount the beast? –  Marty Fried May 31 '12 at 16:51

that is a mess. If possible I'd recommend just starting from scratch :-/ If that's not possible....I hope you're good at backing up because there is a fair chance you'll hit snags. I've never seen such a messed up partition setup (no offense). What is /media/BOOT? Let's start with that one.

share|improve this answer
    
On first glance, it looks like a dedicated grub partition, which is mounted as /boot. What's the big deal with that? –  Marty Fried May 29 '12 at 23:05
    
And use UUIDs instead of device names, if I got you right, that would fix your problem in the first place. Using blkid on device files will tell you the UUID, label and file system. –  LiveWireBT May 29 '12 at 23:07
    
Oh yeah. I did (do) dual-booting, and change primary OSes sometimes without writing a new main bootloader, so I use a dedicated GRUB. –  WindowsEscapist May 31 '12 at 0:05
    
On a side note, I've never once backed up and never had data loss! ^_^ (dangerous, much) (Only because I don't have another 500GB drive) –  WindowsEscapist May 31 '12 at 14:25
    
@WindowsEscapist, if you have a dedicated grub partition, it should be mounted in /boot/grub, not /media/Boot. It isn't going to be used by grub mounted there. –  psusi May 31 '12 at 14:40

You should really start looking and use LVM2 if you want that many partitions. It will make your life a lot easier. And it work with all major linux distributions but not by MS Windows or OS X.

You start by format disk space to a Linux LVM partition as a physical devices (pd). These pd usually are located on disk partitions with id set to 8e. They can then be combined into something called volume groups (vg). These volume groups can be from different disks, but are treated like on partition on ordinary disks. You can later add or remove pd to/from these vg. Lastly you create your logical volumes (lv) by partition them out of a vg. So these lv are used like partitions from a ordinary disk. But you can easily add and remove them later without the need for partitioning your disk. These lv you can format and mount as any ordinary partition on a ordinary disk. The difference is that this is much easier to administrat and change size later.

share|improve this answer
    
Sorry, but LVM2 is not an option for me. There were (if I recall) several Windows partitions listed there as NTFS; one of an old, broken install labelled as Acer, one blank labelled "Windows 7", and one labelled "Secondary Windows" (I plan to dual-boot XP and 7 once I get the chance and the time) –  WindowsEscapist May 31 '12 at 0:07
    
Plus, that doesn't answer my question at all. I appreciate the effort though; I wouldn't imagine that many would want to wade through fstab. Also on the bad side, changing to LVM or LVM2 would require complete reinstallation and formatting of that whole disk. You have to have something important if you keep around a dead Windows partition as primary! /joke –  WindowsEscapist May 31 '12 at 0:09
    
Yes, but that doesn't say that you can't use LVM2 for you linux installations. You have problems which will be solved by LVM2, if you have restrictions that is not named in the question, the we can't adjust to them, can we? No, you can change one partition to LVM and start to migrate other partitions to that LVM. No need to reinstall, but some manual work to do. Once you have partitions in the LVM, it is easy to add and remove physical partitions, as long as there are enough space left for the logical volumes in the volume group. you could start with one of the unused windows partitions, and –  Anders May 31 '12 at 8:38
    
"Restrictions" are named; they're clearly shown in both my fstab and GParted graphical representation. I appreciate the tip on LVM2, which I indeed used for a little bit, but dropped it after I realized that Windows did some pretty odd things and Fedora and Ubuntu conflicted a bit with implementation. –  WindowsEscapist May 31 '12 at 13:44
1  
@Anders: Why are you trying to push LVM2 on him? This doesn't seem like a good solution as instead of fixing his current problem, it provides several new problems, not the least of which is reformatting all his partitions with a newer system that is not fully supported by various utilities, and might not be good for a novice. –  Marty Fried May 31 '12 at 17:19

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.