Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am trying to use this monitor with my laptop (HP dv7) which I dual boot into a fairly new install of 12.04 Precise Pangolin.

In Windows 7, this monitor "just works" right out of the box. I have it connected to my computer via HDMI and D-SUB cables.

In Ubuntu, the system seems to recognize the monitor just fine (I can tweak it in my Nvidia settings, although "Display" in Preferences reads just one large monitor). I can even see my mouse get "swallowed up" and go off screen (towards the other monitor) when I push it past the application tray on the left.

BUT: nothing is displayed on this monitor, and nothing I do seems to work to get it to display.

My xorg.conf:

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 295.33  (buildd@zirconium)  Fri Mar 30 13:43:34 UTC 2012

Section "ServerLayout"
    Identifier     "Layout0"
    Screen      0  "Screen0" 0 0
    InputDevice    "Keyboard0" "CoreKeyboard"
    InputDevice    "Mouse0" "CorePointer"
    Option         "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Mouse0"
    Driver         "mouse"
    Option         "Protocol" "auto"
    Option         "Device" "/dev/psaux"
    Option         "Emulate3Buttons" "no"
    Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
    # generated from default
    Identifier     "Keyboard0"
    Driver         "kbd"
EndSection

Section "Monitor"
    # HorizSync source: edid, VertRefresh source: edid
    Identifier     "Monitor0"
    VendorName     "Unknown"
    ModelName      "LG Electronics IPS235"
    HorizSync       30.0 - 83.0
    VertRefresh     56.0 - 75.0
    Option         "DPMS"
EndSection

Section "Device"
    Identifier     "Device0"
    Driver         "nvidia"
    VendorName     "NVIDIA Corporation"
    BoardName      "GeForce GT 230M"
EndSection

Section "Screen"
    Identifier     "Screen0"
    Device         "Device0"
    Monitor        "Monitor0"
    DefaultDepth    24
    Option         "TwinView" "1"
    Option         "metamodes" "CRT: nvidia-auto-select +0+0, DFP-0: nvidia-auto-select +1920+0"
    SubSection     "Display"
        Depth       24
    EndSubSection
EndSection

When I try to run xrandr --auto, I get an error:

xrandr: Failed to get size of gamma for output default

Any ideas? I'm up to date on proprietary drivers.

Thank you!!

share|improve this question
add comment

1 Answer 1

If anybody stumbles across this, I got this working. I tried a bunch of different things, and got a fresh install of the NVIDIA drivers.

As it turns out, I was using both the D-SUB and HDMI outputs of my laptop to my monitor (an LG Flatron IPS235) and Ubuntu DIDN'T LIKE THIS.

So, I yanked out the HDMI cable and rebooted.

It worked. :P

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.