Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is the 3rd time i install Ubuntu. And this time it's 12.04. I've been going back to Windows, but keep on coming back! But I just got this one problem, my ASUS EeePC 1215n keeps on overheating when i run Ubuntu!

I've seen that this is a common problem and therefore thought it might be a piece of cake to fix it, but the more i read about it, the more confused I get!

I'm a fairly novice linux user and would really appreciate if someone could help me out with a step by step instructions to how to fix this! (even include what I'm supposed to write in terminal).

What I've understood from most posts I've read is that the nvidia Ion2 driver needs to be disabled? I guess it's because it just goes haywire even though it's not being used...right? will this solve my overheating problems?

I'm sorry for this being a repost, but like I said, this is my 3rd time around and all my searching really hasn't got me any further down the road!

share|improve this question

4 Answers 4

up vote 2 down vote accepted

If your BIOS has an option to use the Integrated graphics chip, configure it to do so in order to disable the nvidia card -> lower temperature.

If you intend to use the discrete nvidia card sometimes, have a look at Bumblebee. See also How well do laptops with Nvidia Optimus work?

share|improve this answer
    
Amazing! This is exactly what I was looking for. I followed the guide you linked to and as I'm writing this comment, my fan is for the first time ever slowing down! Thanks so much! –  cazyius May 30 '12 at 20:34

If you have Nvidia optimus try installing the new beta version of Nvidia 319.12 with bumblebee.

sudo apt-get remove bumblebee-nvidia nvidia-current nvidia-settings

sudo apt-get install bumblebee-nvidia nvidia-319 nvidia-settings-319

Link http://orkultus.wordpress.com/2013/04/20/how-to-nvidia-319-12-drivers-in-ubuntu-based-systems-with-bumblebee/

share|improve this answer

Check for factory overclocking in the BIOS , it's usually indicated by Easy Overclock setting and it should be factory set to 3%. IF so disable it, my laptop also an ASUS had that and for some reason that i can't figure out , ubuntu couldn't control the cpu speed so it was always running 100%. Also i had a lot of dust in the heatsink so i'd suggest you check your vents for dust (blow in them(while laptop is off obviously) and see if a puff of dust comes out). Install bumblebee following the advice above. This is what should hopefully solve your problem since i haven't heard of a specific problem in ubuntu that would cause an overheat or any other kind of hardware damage. (This is not guaranteed to work since it's not a fix or a patch it's just steps to fix overheating in general)

share|improve this answer

You can also run powertop to investigate where energy is used most. You can also use optimize option to see it produces less heath. But for permanent setting there is some work to do. Please search on google by powertop.

sudo apt-get install powertop

Also install tlp as follows

sudo apt-get install tlp

or install the package by hand: https://launchpad.net/~linrunner/+archive/tlp then

sudo tlp start

I am not sure if it is possible with Nvidia. I use ATI and it produces less, a lot less heath when memory frequency is underclocked. for example ATI5970 supposes to use memory clock 1100 Mhz, it can run stably for day with lower memory clock, even with 300 Mhz. So try underclock the memory frequency.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.