Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I try to use a live CD, My Dell XPS 14z will not read the disk and skips to booting windows, I've had previous questions discussing this but everything I have tried never works.

I'm almost absolutely sure that I am not burning the CD wrong, because windows recognizes it as a Ubuntu install disc. But when I boot from CD drive it never reads the CD!

I used to have a wubi installation, but I uninstalled it, when I try to reinstall it I get an error. I forgot what it is but i will post it later in a comment. I've tried to use the boot CD helper (whatever it's called) But I get an error there too, again I'll post it in the comments. Also, I have had absolutely no problem in the past installing Ubuntu on other computers.

The first thing I did when I tried to install ubuntu is to make sure the priority was set to boot from cd drive. so that isn't the problem.

Could windows be interfering with the installation of Ubuntu? Should I do a clean install of windows then try Ubuntu?

share|improve this question

You probably have to change the boot order. For most Computers the boot order is set in the BIOS. You will have to hit and hold a special key after you turned your computer on. Most likely its Shift or Tab or one of the F-keys. Your machine will give you a hint on the boot screen.

Set the boot order to:

  1. DVD/CD-Rom
  2. HDD
  3. ...

Then your computer will try to boot from your CD/DVD-Drive first, then from your Harddisk.

share|improve this answer

There is no way windows can interfere with the boot process, assuming you are doing a full bootup, not simply waking up from hibernate or suspend. At that time, windows is not running; in fact, no operating system is running. Only your computer firmware can have any effect.

The computer's firmware is controlled by the BIOS setup, which has a setting for the order of devices to look at to boot. If you're really not about the CD, you could set the BIOS to boot only from the CD, and no other devices. Then, if the CD is not bootable, you will get an error when it tried to read it. But in any case, you should be able to tell if it tries to access the CD before booting the HD. If not, then it is not set correctly.

share|improve this answer

Short answer is no. You went to your bios and made sure boot from CD is before boot from hard disk? Also, if you have a thumb drive highly recommended to install from a thumb drive. You can make the bootable thumb drive easily using unetbootin (in Windows or Linux)

share|improve this answer

Yup. Double-check your boot order or use the F12 (or other hotkey) boot menu to change the order to manually boot from CD. This has nothing to do with Windows or other hard disk stuff.

If you still want Wubi, run wubi.exe in the same directory as the .iso file and voila! from within Windows. Don't use the CD. If you want a dual-boot (something else entirely; wubi uses a virtual hard drive), then CD is the way to go. I would recommend true dual-boot, but it sounds like Wubi is more your speed right now.

(The somewhat-cloudy-eyed leading the blind!)

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.