Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I've installed Gvim and synaptic package manager on 12.04, Gvim had a warning each time I ran it from terminal. So I removed it and tried to install again but came with the following error from software center:

The following packages have unmet dependencies:

vim-gnome: Depends: vim-gui-common (= 2:7.3.429-2ubuntu2) but 2:7.3.429-2ubuntu2.1 is to be installed
       Depends: vim-common (= 2:7.3.429-2ubuntu2) but 2:7.3.429-2ubuntu2.1 is to be installed
       Depends: vim-runtime (= 2:7.3.429-2ubuntu2) but 2:7.3.429-2ubuntu2.1 is to be installed

I disabled repositories from software center and just enabled the "main" and the error is still present, software center crashes sometimes too.

What should I do so?

share|improve this question
    
I guess the problem is unsuccessful remove of gvim because when I try to install the gvim, it's icon appears on the launcher, but the error comes after that, the other opportunity is incompatibility of synaptic. –  a-z May 29 '12 at 18:51
    
there is a common warning with gvim due to not supporting the global menubar. There's a way to get rid of it, but it's not something to worry about. –  Marty Fried May 29 '12 at 19:05
    
@MartyFried: I've got these: "(gvim:5122): Gnome-WARNING **: Accessibility: failed to find module 'libgail-gnome' which is needed to make this application accessible (gvim:5122): GLib-GObject-WARNING **: cannot retrieve class for invalid (unclassed) type `<invalid>'". Is it that? –  a-z May 29 '12 at 19:07
    
No, I'm pretty sure that's a different error message; sorry, I don't remember the exact one I used to get - I use Gnome classic, not Unity, now. –  Marty Fried May 29 '12 at 19:15
add comment

2 Answers

up vote 0 down vote accepted

I think you need to also enable the update source.

This look like it try to install a old version of gvim while there is a newer version of some components installed, and a strict version checking.

share|improve this answer
    
what can I do that Ubuntu forgets everything about Gvim? –  a-z May 29 '12 at 18:57
    
It looks to me like it's trying to install the same version, not an old version. Just look at the versions in the error message - they are the same. –  Marty Fried May 29 '12 at 19:10
    
But not the same release : 2:7.3.429-2ubuntu2 and 2:7.3.429-2ubuntu2.1 , note the .1 in the end, so this was a update. See packages.ubuntu.com/precise-updates/vim and packages.ubuntu.com/precise/vim –  Misc May 29 '12 at 19:11
    
I see - same files, same version, but from an updated repository, I assume. I thought it was a different problem, probably because I don't pay that much attention to the update process. I just update what it tells me to, and haven't needed to know the details (fortunately). –  Marty Fried May 29 '12 at 19:20
add comment

Try to remove "vim-common":

$ sudo apt-get autoremove vim-common

And then install "vim" with:

$ sudo apt-get install vim

This will install correct version of "vim-common", and later you can install GVim through the software package manager.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.