Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am using Ubuntu 12.04.

My /etc/network/interfaces file consists of:

# The loopback network interface  
auto lo  
iface lo inet loopback  


# The primary network interface  
auto eth0 
iface eth0 inet static  
address 192.168.1.58  
gateway 192.168.1.1
network 192.168.1.0  
broadcast 192.168.1.255
dns-nameservers 66.212.63.228 66.212.48.10  

I ran the command: /etc/init.d/networking restart

Which responded with:

*Running /etc/init.d/networking restart is deprecated because it may not enable again some interfaces  
*Reconfiguring network interfaces...  
RTNETLINK answers: File exists  
Failed to bring up eth0  
[ OK ]  

Next I ran ping google.com and received:

ping: unknown host google.com

I am not sure if my interfaces refreshed. How do I properly configure my network with my static DNS addresses?

share|improve this question
1  
Reboot your computer. Do not run /etc/init.d/networking restart. The error is caused by the default route already existing. This setup looks correct to me. –  Matt H Jan 27 '13 at 22:42
1  
As Matt H says, /etc/network/interfaces is picky about stuff already existing. You can have a perfect setup, but already have something there, and it will complain. If it is the default route it is complaining about, you can remove it by running ip route del default to get the computer into a state where you can hand over the management of this stuff to /etc/network/interfaces –  Azendale Mar 31 '13 at 19:56

7 Answers 7

Command line version:

You should add your nameserver(s) to /etc/resolvconf/resolv.conf.d/base file this way:

nameserver 66.212.63.228 
nameserver 66.212.48.10
share|improve this answer
    
I will have to try this method in a few hours and get back to you. Do you know why I am receiving the deprecated message and the failed to bring up eth0 message? –  dottedquad May 29 '12 at 20:15
1  
You could use this:$ ifdown eth0 && ifup eth0 Read more about this issue here. –  pl1nk May 29 '12 at 22:05
1  
@dottedquad what is you change the /etc/network/interfaces file to this: auto lo iface lo inet loopback auto eth0 iface eth0 inet static address 192.168.1.58 gateway 192.168.1.1 network 192.168.1.0 broadcast 192.168.1.255 Take care that this: auto eth0 iface eth0 inet staticis two lines –  pl1nk May 30 '12 at 0:17
1  
It is better to add nameserver information to NetworkManager connections (if you are using NetworkManager) as described by bodhi.zazen, or to interface definitions in /etc/network/interfaces (if you are using ifup) than to add the information statically and globally to /etc/resolvconf/resolv.conf.d/base. –  jdthood Oct 30 '12 at 8:21
1  
@jdthood It seems that you have seen my comments and the question as well as the other answers! Some comments up [..] "You could use this:$ ifdown eth0 && ifup eth0"[..] –  pl1nk Nov 1 '12 at 13:19

Easiest method of configuring your DNS servers is to use NetworkManager

Under IPv4, fill in your dns server(s)

enter image description here

share|improve this answer
2  
I forgot to mention that i do not have unity or gnome installed. Gnome installatio is my next project. –  dottedquad May 29 '12 at 20:13

You are missing a subnet specification in the interfaces file.

Add netmask 255.255.255.0 to /etc/network/interfaces below the network line.

share|improve this answer

As the questioner gives the contents of his /etc/network/interfaces I infer that he is using ifup to configure interfaces. But since he may actually be using NetworkManager, I will discuss that as well.

If you are using ifup then DNS settings go in /etc/network/interfaces. For each interface you add dns-* options appropriate for the nameserver(s) available over that interface. E.g., if a nameserver at address 1.2.3.4 is available over interface eth0, then add dns-nameservers 1.2.3.4 to the iface eth0 stanza.

If you are using NetworkManager then settings are entered in the Connection Editor (network indicator | Edit Connections...) in the IPv4 Settings tab.

Doing /etc/init.d/networking restart to reconfigure interfaces is deprecated. If you are using ifup then first ifdown each active network interface, then ifup each interface. If you are using NetworkManager then, first, disable networking using the indicator (top of the desktop); then open a terminal and run

sudo restart network-manager

and then enable networking using the indicator.

Or you can just reboot.

Regarding the fact that /etc/init.d/networking restart resulted in

RTNETLINK answers: File exists
Failed to bring up eth0  

This means that ifupdown thinks that eth0 is already up. Use "ifdown --force eth0" to cause ifupdown to stop believing that it has already configured the interface.

Regarding the "deprecated" message, this message is no longer printed in Ubuntu 12.10 but you should still note that initscripts are "on their way out". To restart a service foo, use service foo restart or restart foo. Note also that if you want to reconfigure your interfaces it is better to ifdown them one by one than to rely on restarting "networking".

share|improve this answer

If none of the above work, keep it mind that Ubuntu appends a tail file to the resolv.conf file that it generates.

Try this:

sudo nano /etc/resolvconf/resolv.conf.d/tail

Which will open a blank resolv.conf.d file in the nano text editor. You will need to place your DNS server address on the first line of this file and remember to end the line with a carriage return (hit enter) as seen below:

nameserver 10.20.1.2

Editing the tail file instead of the actual resolv.conf file will prevent your change from being lost upon a system reboot.

You will need to run sudo resolvconf -u to activate the change. You should be able to ping google.com after this. Good luck!

share|improve this answer

I use

sudo ifdown eth0

then

sudo ifup eth0

It will reset and release everything...

share|improve this answer

I was able to work around this on a headless ubuntu server install by adding

nameserver 8.8.8.8

...after the relevant interface stuff in /etc/network/interfaces:

auto wlan0
iface wlan0 inet static
address 192.168.1.28
netmask 255.255.255.0
gateway 192.168.1.1
dns-nameservers 8.8.8.8
dns-nameservers 8.8.4.4

Hope this helps later users!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.