Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a Windows 7 User and decided to install Ubuntu 12.04 on my Notebook Dell Inspiron N5110 and when the Grub loads with the menu list, the fan starts speeding up. If I choose Windows, the fan is noiseless; but, if I choose Ubuntu it continues speeding up and overheating.

If there is a solution for this. I wonder if someone could spend some time helping me out because I have JUST bought this notebook because it is in the list of Certified Hardware: http://www.ubuntu.com/certification/hardware/201012-6931/

So you linux wonderful guys help!

share|improve this question

5 Answers 5

Ya the overheating problem, unfortunately, Ubuntu developers haven't solved this issue, even though they say install 11.10, well my fellow Linux friend, 11.10 won't solve your issues. I have the exact laptop you do, and it still overheats, when I use to run 11.10 or the new LTS 12.04. Apparently the Ubuntu developers don't know how to fix this fan clock bug. But I did the next best thing and bought a cooling pad. Don't spend more than 50 bucks though for this band-aid fix. I only spent about 30 for a dual fan USB cooler. Now that's in Canadian dollars though.

I have researched for almost a year now why Ubuntu has this silly laptop overheating problem and I can't find a useful thing that actually solves this issue except for installing "Jupiter" for Ubuntu, this does help a bit, by choosing things like performance levels, which include "max performance" "Power on Demand" and "Power saver". Well all this seems to do is slow down video graffics while trying to view video, or even such simple tasks as playing angry birds on facebook.(This happens on my girlfriends older Acer laptop) But seeing that you have an Inspirion 5110 this shouldn't be an issue since I have the same laptop. Mine is an i5 Intel Core.

I really hope you buy a cooling pad though, keeps temps down. In my opinion it's a toss up between getting viruses, spyware, malware infecting your computer using windows while surfing the web. I choose buying a simple cooling pad, didn't cost much, saves my laptop from overheating, and I can surf the web without constant virus attacks.

Now, as for installing "Jupiter" on your Nice Dell Laptop simply open your "Dash" type terminal and open it, copy and paste the following, one line at a time, then restart and you should have a lightening bolt icon on your top task bar, there you should be able to choose your CPU power consumption.

From a terminal, run the following commands:

sudo add-apt-repository ppa:webupd8team/jupiter
sudo apt-get update
sudo apt-get install pyjupiter
sudo apt-get install jupiter-support-eee

Like I said, it doesn't seem to matter about the version of Ubuntu you use(like the person above replied to you) when it comes to this issue, simply buy a cooling pad, and do the above. I suggested sticking with Ubuntu 12.04 LTS, since the LTS stands for Long Term Release, which is supported for the next 3 years. Kind of like Microsoft does with their support. When it comes to Ubuntu always stick with LTS, due to the fact of Long term support. As a Dell Inspirion 5110 user I really love using this O/S, Windows actually blew my speakers on this Laptop, While using Ubuntu(GNU/Linux) I haven't had a problem, also my girlfriend uses Ubuntu 12.04 on her Acer(2years old) and has never seen the "BLUE SCREEN OF DEATH" since switching to Linux from Windows.

We all have some reason to use Microsoft, but as for free goes I choose Linux, which also doesn't force you to get rid of your Main O/S, unlike Windows. If you wan't a virus free fully perfect system you could always buy a MAC, also remember the historic fact the Apple actually has part of the Linux line of code(Kernal) inside it. This is also why you don't need a virus scanner in Mac as well as Linux, Unlike Windows, which is a decent O/S but the Costly Virus Scanner Subscriptions and constant maintainance from infected root files, just doesn't add up over the years. If you have the means I suggest buying a Mac, but if you can't afford it, stick with a second O/S and run LINUX. It's up to you. But don't go on hating something you are new too, take your time then make your opinions public.

Hope this helped.

share|improve this answer
    
Well, fellow! Today I was prompted for updates and there was a new Kernell... But the guys still haven't graced us with a bug fix! Well, fellow... I will consider bying a very brand new cooling pad! By the way... I trying to install jupiter. But got conflicts with touchpad-indicator. So far so good... thanks very much! I enjoyed your 'conversation'! hahaha –  Gilberto Albino May 31 '12 at 15:07

You could take a look at this article (it's from my blog)

Keenformatics - How to solve Dell laptops fan issues in Ubuntu

and at this discussion here on askubuntu:

Dell Inspiron 5521 i7-3317U Fan CPU too Noisy

Here are the main steps as written on that site.

How To solve Dell laptops fan issues in Ubuntu

  1. First of all, let's download and install i8kutils. Open your terminal and write:

    sudo apt-get install i8kutils

  2. Now you've got to add i8k to your modules. Open the modules file:

    sudo gedit /etc/modules

    and add the string "i8k" (without quotes) to the file. Save and exit.

  3. Create an i8k.conf file

    sudo vim /etc/modprobe.d/i8k.conf

    and fill it with this code:

    options i8k force=1

    Note: Some older guides will tell you to create a /modprobe.d/options file. The "options" file isn't used anymore on Ubuntu. What does matter is that you create a file with a .conf extension (the filename isn't important, but I decided to name it i8k.conf for clarity). So beware of older i8kmon configuration guides.

  4. Now restart your computer, or run this code to make i8k run:

    sudo modprobe i8k force=1

  5. We will now create a i8kmon.conf file which will tell the i8kmon utility how to behave.

    sudo gedit /etc/i8kmon.conf

    Paste the following code in it:

    # Run as daemon, override with --daemon option
    set config(daemon)      0
    
    # Automatic fan control, override with --auto option
    set config(auto)        1
    
    # Report status on stdout, override with --verbose option
    set config(verbose) 1
    
    # Status check timeout (seconds), override with --timeout option
    set config(timeout) 20
    
    # Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
    set config(0)   {{-1 0}  -1  40  -1  40}
    set config(1)   {{-1 1}  30  60  30  60}
    set config(2)   {{-1 2}  53  128  53  128}
    
    # For computer with 2 fans, use a variant of this instead:
    # Temperature thresholds: {fan_speeds low_ac high_ac low_batt high_batt}
    # set config(0) {{-1 0}  -1  52  -1  65}
    # set config(1) {{-1 1}  41  66  55  75}
    # set config(2) {{-1 1}  55  80  65  85}
    # set config(3) {{-1 2}  70 128  75 128}
    
    # end of file
    

    This has been edited to match my Dell Inspiron 15r 5521 fan configuration (and I hope I did it well). If you want more informations take a look at the documentation on Ubuntu Manuals: http://manpages.ubuntu.com/manpages/gutsy/man1/i8kmon.1.html

  6. Now you should be able to run i8kmon from your terminal and see if (and how) it's working. Simply run:

    i8kmon

Finished!

share|improve this answer
    
Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  Kevin Bowen Jun 23 '13 at 10:16
1  
Ok, I've added the steps :) –  Kurt Bourbaki Jun 24 '13 at 11:24

Seems to me you've propably set in your ways with windows and don't want to bother exploring linux. Your post is not a question but a rant against ubuntu/linux.

Anyway, your laptop is overheating because it has 2 graphics cards, 1 inside the processor and a seperate dedicated nvidia card. It is based on an nvidia technology named "optimus". The cpu graphics card is responsible for the majority of rendering and the nvidia kicks in whenever and demand for higher graphics occur. In that case the nvidia is processing the image on a seperate buffer and when it's done, it renders it through the cpu card.

For that whole thing to work, special nvidia optimus drivers are required, and nvidia didn't provide linux with such. You will notice the same over heating behavior in windows also if you remove the drivers since the nvidia card cannot tell when it is not needed and keeps running full-power all the time.

Fortunately a group of linux developers managed to deal with the mess nvidia created with "optimus" , by making the project "bumblebee" . With that installed your linux kernel will be able to identify the nvidia card and shut it down unless you invoke it for a specific application your self. Enough with theory...now to the practical part:

1)Remove any proprietary nvidia drivers you have installed from your ubuntu. If it's a fresh ubuntu 12.04 installation you are good to go.

2) Fire up the terminal and give the commands:

sudo add-apt-repository ppa:bumblebee/stable

press enter when asked.

sudo apt-get update
sudo apt-get install bumblebee bumblebee-nvidia

After te process is done reboot you laptop and enjoy your cool & quiet laptop.

Also, to use a heavy application with the nvidia card simply , open a terminal or use the alt+F2 command exec , and type the word "optitun" before the name of the application you waknt to start. For example:

optirun firefox

If you want to compare the performance bettween the 2 cards you can do the following:

Open terminal and type

glxspheres

now monitor the framerate of the animation. then close it and type in the terminal

optirun glxspheres

The difference should be obvious ;-)

share|improve this answer
    
I really bother about linux fellow! I'm trying to use Linux since 2004 and haven't got success! As I said there is always a bug or hardware incompatibility. And I just can't spend hours trying to fix problems while I DO HAVE to work. I am a web developer for over 11 years now. PHP Programmer and use Linux on my dedicated server. I am not even a new comer to Linux: I mean using Linux as Desktop OS has been a real pain in the neck and frustrating experience! However, no complaints about linux server! –  Gilberto Albino May 31 '12 at 14:59
1  
Forgot to mention... I have an AMD Radeon 6400 HD Series –  Gilberto Albino May 31 '12 at 15:04
    
@GilbertoAlbino: Have you tried this? Did it work? –  Beni Bogosel Jun 13 '12 at 12:58
    
@kami84gr I tried this on my DELL N4110 and didn't work. When I try to run bumblebeed it raises "[ERROR]No discrete video card found, quitting". Any idea? –  Ricardo Acras Feb 27 '13 at 15:02
    
@RicardoAcras What kind of hardware do you have? Bumblebee only supports hybrid graphics for nvidia optimus. –  VasPle Mar 6 '13 at 8:58

Instead of starting out with the latest distro....how about going to Ubuntu 11.10. Of course there are going to be kinks to be worked out considering how short of a time period that 12.04 has been released for upgrade.

From my own personal experience I have had no issues running Ubuntu 11.10 on machines built to handle XP (8 year old machines). Before tossing in the towel prematurely on Ubuntu I would suggest trying a different version of Ubuntu.

share|improve this answer

This worked for me on Dell inspiron 3521 - Ubuntu 13.04 . Less sound of fan webupd8.org/2011/06/linux-kernel-power-issue-fix.html (Using tlp as well - webupd8.org/2013/04/improve-power-usage-battery-life-in.html)

share|improve this answer
    
As you all guys can see this an old post. I've switched to Fedora since I could'nt fix the problem and got all working fine. With the very new release of Ubuntu 13.04 everything is working like a charm. –  Gilberto Albino Jun 24 '13 at 11:52
    
I am facing issue even with 13.04 :( I had to follow these tricks to reduce sound. I just posted in case it helps someone else. –  mac Jun 24 '13 at 18:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.